Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Any one else had lift pump problems ? My truck has only 11,000 miles & started surging real bad the other day. Carried it in & they ordered new lift pump....They called me today & said the New lift pump started surging Real Bad when they took it for a test driven. Mechanic had to use both feet on the break to get the truck stopped ......so they ordered another one that should be in Monday. Anybody else had any lift pump issues ?
 

·
Banned
Joined
·
2,046 Posts
I call BS:BS::BS: on that "mechanic"!! A surging LP is gonna affect the way the truck drives???!!! After the CP3??? Are you sure your info is correct??
:beer
 

·
Banned
Joined
·
4,630 Posts
Like dorkweed said, a bad lift pump would not cause problems like that....doubt the CP3 in itself could either. Possibly pressure relief valve?? Not sure what the symptoms of a bad one are...
 

·
Registered
Joined
·
2,147 Posts
tell the mechanic instead of burning up your brakes, maybe just shift it into NEUTRAL???
 

·
Registered
Joined
·
55 Posts
Discussion Starter #5
O.k. fist symtons ocurred a couple days back when my wife was driving. Asshe was slowing to go into some 20mph "s" curves the truck started surging , she put on the breaks & pulled off the road & killed engine. A minute later she tried to start truck again & it would turn over but wouldn't start. She waited about 10 minutes & truck started & she drove home real slow. I took truck to dodge service manager. He's a friend of mine & drives a truck like mine. He hooked up his lap top thingy & everything reads fine. He cleared serv engine lite "which was some fuel type code" & then drove 30 miles with it hooked up & all was well. That nite I started truck & it surging Real bad. I shut it off & drove another truck to work. Next morning truck started fine , no surging but engine lite was on. Took kid to school & dropped off truck at dealer . Get a call midday saying they're replacing lift pump cause that's what code & symptons point too. .......Now after installing new pump & mech drives it , it does same thing , surges real bad. They ordered another new pump should be here Monday.
 
1 - 5 of 5 Posts
Top