Dodge Cummins Diesel Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
installed a Kool Vue tow mirror on my left side. I have not gotten to the right yet. Already have issues.

I see ashultz91 posted on one message about this but never got an answer. I tried to PM him here on the board but his box is full and I dont think he been around in a while.


Biggest is that the mirror ran for a second then died. Now the right doesnt move either so Im assuming fuse. Did anyone find a difinitive answer ?

Also the stud on the top comes in too far and hits my Mirror control switch so I cannot finish putting on the door panel.


Ideas (Sorry no grinder)
 

· Premium Member
Joined
·
12,665 Posts
wire pinched, and as for the studs being too long, they are supposed to be, to support the wieght of the mirror, you can get a bracket at the dealer that will make it fit..:thumbsup:

there's also a site that sells em, i have it bookmarked on my home comp, if no one posts it by then, i'll link ya to it...:party018:
 

· Registered
Joined
·
64 Posts
wire pinched, and as for the studs being too long, they are supposed to be, to support the wieght of the mirror, you can get a bracket at the dealer that will make it fit..:thumbsup:

there's also a site that sells em, i have it bookmarked on my home comp, if no one posts it by then, i'll link ya to it...:party018:
Had the same problem with mine, i pinched the wires and kept blowing fuse's. Make sure u run the wire in the channel behind the mirror.Also you need the tow mirror brackets so the studs on the mirror are perfect size!!:thumbsup:
 

· Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Thanks, I took care to not pinch any but Ill check. Also the heater Blew the fuse too ... UGH.

I bought the brackets from Fenderworld to put it in there and that works ok. Just the top stud is so far out that it occupies the space that the switch would normally stick into. Door panel is loose (the screw right by the switch) right now .. so bugger all.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #9 ·
CRAP ah is stupid

There is no install instructions so I ran the wire best I could. Got it pinched in the plastic lip. 4 wires were pinched not broke so I used seal tape on them. 1 was broke so soldered it then seal taped it. Works fine. Ill install the right side correct when I do it tomorrow.

Now to figure out what to do with the stud that is interfering on the switch.

Guess Ill have to try a hack saw
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top