Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter · #1 ·
Just got done with the 5" TBE to dual 4" from BADP. I can't say that I am 100% satisfied with the whole experience, but I am definately enjoying the kit. Finally got to get even with one of the motorcycle guys that always pull right up on my back bumper. Dual exit pipes with the MP-8 and edge turned all the way up definately don't agree with an open helmet. I let out enough black smoke that I couldn't see him through it. Exhuast temps did drop, but haven't gotten an exact drop yet. I love the sound. With duals you can only get it with a muffler, which turned out to be perfect for me. Enough sound when you get on it, but no drone sound anywhere through the powerband. Mileage has also begun to climb fast as long as I keep my foot out of it as well. I had to customize one hanger on the extension pipe because it was welded about 12" short of the hanger that it was supposed to hang from. Definately alot of room for adjustment in the pipes which helps getting them adjusted just right. I was missing some clamps which I will contact them about tomorrow. They listed it as a 5" dual kit with 6" tips, which I thought was 5" all the way back, but they said the only way it comes in duals is 4" with 5" tips. Like I said overall I'm pleased with the kit, but if they get their website worded a little clearer and fix the minor things, it would be a perfect system.
 

·
Braaap, Braaap, BOOM!!!
Joined
·
6,126 Posts
Congrats on your dpf delete. Can you get some pics for us on your set up and maybe a vid?
 

·
Registered
Joined
·
331 Posts
Enjoy the smoke now. When you do the EGR delete you will lose the smoke. Congrats on the delete.
 

·
Registered
Joined
·
102 Posts
I just did the same exact kit from BADP also missing clamps and also dissappointed with the online description. I also bought the kit thinking it was mufflerless so I bought an additional muffler to add if to loud. So i got charged for a kit with a muffler and a muffler that they didn't send me. But I am happy with the kits end result. But my truck just has a little puff of smoke with mp-8 and edge turned all the way up. Also i had no instructions of any type and i'm just wondering if there is a preference for the black box plug? can they go to any sensor?
 

·
Registered
Joined
·
144 Posts
was the hanger on the piece before the muffler welded to where it looked backwards and way too far from the mount on the truck? magnaflow was way off on mine
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #6 ·
I just did the same exact kit from BADP also missing clamps and also dissappointed with the online description. I also bought the kit thinking it was mufflerless so I bought an additional muffler to add if to loud. So i got charged for a kit with a muffler and a muffler that they didn't send me. But I am happy with the kits end result. But my truck just has a little puff of smoke with mp-8 and edge turned all the way up. Also i had no instructions of any type and i'm just wondering if there is a preference for the black box plug? can they go to any sensor?
Mine had the plug and play for the three temp sensors, and I didn't have any certain way I hooked mine up. I just put the end ones to the ends and the middle one to the middle just so the wires were long enough.
 

·
Registered
Joined
·
130 Posts
Discussion Starter · #7 ·
was the hanger on the piece before the muffler welded to where it looked backwards and way too far from the mount on the truck? magnaflow was way off on mine
Correct. It was on the piece that is supposed to be used for the megacab before the muffler. the clamp wasn't necessarily backwards, just about a foot away from the factory hook. I don't know if it is a pipe from Magnaflow, or if it is BADP's pipe. Still haven't heard back from anyone there about the missing pieces. Left a message because it seems like I can never catch anyone there when I call.
 

·
Registered
Joined
·
395 Posts
was the hanger on the piece before the muffler welded to where it looked backwards and way too far from the mount on the truck? magnaflow was way off on mine
The kit is for a 5.9 truck that is why the hanger is facing the wrong direction...or so i've been told.
That is the only one that i didn't mess with and other than that all of the others fit ok....kind of tight and at angles but they still fit none the less.
 
1 - 8 of 8 Posts
Top