Dodge Cummins Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
The install went real good very happy witht the product and instructions. It was a tight fit under my 2wd short bed I will get some pics up tommorow finished kind of late tonight.

pump is also very quiet

Now when I first drove the truck it had about a 1/8th tank. under hard acceleration the pump makes a whinning nosie. I have heard that is because of air in the system inbetween the pump and the tank. so I went and filled the truck up 25 gallons at $111.51 :$:
well when I pulled out I wanted to see if it was still whinning and sure enough it is it almost sounds like a supercharger under my truck. I installed diesel safe thread sealant on all npt fittings and everything is tight. Nothing is leaking under my truck. Guess I am going to have to start checking some connections tommorow...
 

·
Registered
Joined
·
72 Posts
Discussion Starter #2
Oh and most importantly Thanks to GUS at FarmBoysDiesel.com Great service and fast shipping...
 

·
Registered
Joined
·
609 Posts
is the drain knob tight on the water separator???if it isn't...might be sucking a little air..
 

·
Registered
Joined
·
72 Posts
Discussion Starter #4
it is tight I checked it last night. I am going to check over the fittings again later but it only does it at about 2k rpm and up under acceleration and I filled the tank to the top.
every npt fitting has thread sealant on it. I know they are supposed to make some noise but this thing screams...
 

·
Registered
Joined
·
609 Posts
are you sure you haven't kinked any lines during install...the AD150 I installed for a buddy had a similar problem...come to find out...I kinked a line on the suction side from the tank..made the pump sound really strange..once I unkinked the line...all was good.
 

·
Premium Member
Joined
·
1,549 Posts
mine whines a little bit also but its up under the cab where I mounted mine so its easier to hear the noise from it. fass pumps are pretty loud also they all make some noise. so far im pretty pleased with mine it seems to work pretty well. I like the fact its got 1/2" fuel lines instead of 3/8".
 

·
Registered
Joined
·
72 Posts
Discussion Starter #7
ya I checked the lines before I ran the truck and everything looked great the only thing I could think of is maybe it is getting air where the drawstraw has the brass Npt that threads into the tank fitting where the grommet is, where it goes from the plastic straw onto the brass. and I expected some noise but it sounds like my buddy's F150 harley truck with a ken bell supercharger it whines pretty damn lound and with the windows up you can here it under the floor.

When the truck is off and the pump comes on you can barley hear it. with the truck running you can't hear it at all even if you stick your head under the truck but that might just be my 5"TBE. but if you touch the pump you can feel it vib a little...

when you get on it and the truck goes over 1800 rpm it gets lounder you can hear it over my exhaust and turbo.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #9
:lol3:LOL nope just figured that out because yesterday it blew the intake manifold gasket out and was leaking all the boost out.... I knew something was up with that sound it just didn't seem right ,and I learned the hard way but oh well the gasket is only $20 :$: and I get to work on my truck some more and get to now the cummins that much more....


But I am still having a dead pedal issue at WOT around 2-23k and at 68-75 MPH and if I back off and then get back into it everything is good but then it does it again. But I am not getting a APPS code I am getting the P0216 which looks like I might learn how to do a VP44 Install... I am going to try to reset the APPS before I spend a thousand bucks


And man I fell like an Idiot not puting those 2 bolts back in, and I got a ton of from my buddy's they keep crackin jokes. but the sad thing is with no boost it still gets better fuel milage then his FORD...
 
1 - 9 of 9 Posts
Top