Dodge Cummins Diesel Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
I have 97 3500 2wd Odo 222,000. Just rebuilt the transmission a couple weeks ago, put in new torque and ran all new trans lines and I've had nothing but issues since. Plugged in a scanner and get 3 codes: PO748, P1763, and P1757. When I try to accelerate from a complete stop, the truck starts shaking and doesn't want to move If I press down on the accelerator, the engine will rev and my rpm will spike . To pick up speed, I have to press on the accelerator lightly. If I press too hard, the engine will again just rev and rpms will spike . The truck tops out at around 50 MPH running 2500 rpms. If I try to press any harder on the accelerator rpms just spike. At first when I would ease off the accelerator I could feel the transmission shifting not sure now if it stays in 2nd or if it manages 3rd Willing to try anything at this point. I had a local shop check it out to see if they could pin point the issue, which then I was told they could not locate the issue and recommended that I retire the truck with all the issues going on with it
 

·
Registered
Joined
·
1,643 Posts
Sounds like the transmission is slipping. You may have cut a seal.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I appreciate giving me something to look into that's different than everything else I've been told
 

·
Registered
Joined
·
1,643 Posts
I would drop the pan and take a look.
 

·
Registered
Joined
·
1,643 Posts
Who rebuilt ur trans?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Me and a buddy of mine done the rebuild, he knew a little more about transmissions than I did so we gave it a go
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
I've had a few people tell me to look into replacing the governor pressure solenoid and transducer saying that could cause these issues.
 

·
Registered
Joined
·
142 Posts
Don't leave us hanging. If and when you figure out the problem or solution, post up and let us know.
 

·
Registered
Joined
·
566 Posts
Fluid smell, color? Next would be drop the pan and have a look. Might be something not requiring a full pull.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
I do have what I believe is torque converter studder pretty bad. That comes from the clutches being bad or wrong fluid right? So could that be the cause of the rest of it?
 
1 - 14 of 14 Posts
Top