Dodge Cummins Diesel Forum banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
131 Posts
Discussion Starter #1
Was driving the road for about 3 hours and the speedo dropped to 40 bounced up to 120 a few times and dinged each time, noticed my fuel consumption went to s*$t for the next 200 miles, before starting the homebound trip I pulled the codes on my reader--(103d,1036 and hvac) my overhead fuel counter shot back up, but about 200 miles it all went fer a s*$t again. (all my guages both dash and pillar were ok including egt) stopped at a store b4 home and all was allright when i restarted. then went crazy again. I am thinking maybe a poor connection but are there any better ideas?? (ps, both the ebrake and abs lights stay on steady when this occurs)
 

·
World Champs!!!
Joined
·
24,829 Posts
Yea thats for sure not a common issue. I may have read of a couple other cases of this happening, but dont recall the issue. Is this an early build date, before 6/06? I believe 6/06 the switched to CAN-BUS. I would think a bad connection would be a better likelyhood on an earlier truck, but Im not electrical guru by any means
 

·
Registered
Joined
·
237 Posts
The lights coming on is exactly what mine did, I didn't notice the MPG though,
I changed the fuses and it stopped, it rained real hard and it did it again, changed the fuses again and it stopped.

I eventually (not related) had to change the batteries and it stopped al together.

Check the fuses and then have your battery or batteries checked. That is the easiest place I can think of to start.
 
1 - 3 of 3 Posts
Top