Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
01 CUMMINS 24 VALVE
EVERY NOW AND AGAIN FOR NO APPARENT REASON i HAVE NO POWER AT ALL IT WILL PICK UP A LITTLE SPEED NOT FAST OR UP HILL BUT MUCH LIKE YOU WENT FROM FIRST TO FIFTH IN A STICK BUT NO SMOKE. i DONT HAVE A FUEL PRESSURE GUAGE YET BUT AM TRYING. FUEL FILTER HAS 2800 MILES ON IT. NO IDEA WHAT THIS IS. AND NO MONEY TO START REPACING RANDOM PARTS!! BETTER YET ITS THE ONLY VEHICLE.
FRANK
 

·
It's got 12 Valves...
Joined
·
4,472 Posts
Check for codes...turn you key on then off, on then off then leave it on the third time and some codes should come up. Let us know what you come up with and we can help out better.

Kinda sounds like a VP issue to me though..but could be other things as well. Check for codes, make sure you are getting good fuel to the Injector pump and go from there :thumbsup
 

·
Registered
Joined
·
182 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
WERE WILL THE CODES SHOW? AND i DON'T THINK IT WILL BECAUSE THE CHECH ENGINE DOES NOT COME ON. ALSO i NOTICED THAT IF I LET OFF THEN PUSH DOWN AGAIN ALL IS WELL.??:rof
FRANK
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
After Thought.... Could It Be The Tps? Or Would That Turn On A Light?
Frank
Should Of Kept The 91.5!!!
 

·
Registered
Joined
·
47 Posts
Mine was doing that same thing. I thought I could drive it for a while but tired of the dead pedal as it started happening more frequently. Mine was a injection pump. P0216!!
Replaced it myself, really easy!!
 

·
Registered
Joined
·
50 Posts
I have the same problem, and the codes are: p1693, p0216. To pull codes is easy as it was told: turn ignition ON and OFF 2 times and on a third time leave it ON and look at odometer. When I took it to the dealer they told it's an injector pump and cost to fix it - $3500 !! I still live with this problem: when it looses the power I pull over and restart the engine and it goes and when I'm on a hiway I let the truck roll for a bit and then press the pedal all the way and it goes.
 

·
Registered
Joined
·
59 Posts
I have the same problem, and the codes are: p1693, p0216. To pull codes is easy as it was told: turn ignition ON and OFF 2 times and on a third time leave it ON and look at odometer. When I took it to the dealer they told it's an injector pump and cost to fix it - $3500 !! I still live with this problem: when it looses the power I pull over and restart the engine and it goes and when I'm on a hiway I let the truck roll for a bit and then press the pedal all the way and it goes.

I had the same problem, and the same solution for a short time. This can be very, very dangerous depending on when the truck acts up.
 

·
Registered
Joined
·
50 Posts
Jeephauler, did you replace an injector pump? and the problem and codes gone? or what'id you do?
 
1 - 9 of 9 Posts
Top