Dodge Cummins Diesel Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
let me say thanks in advance for any input on this issue.

I have a 2015 Ram 3500 about 8 months ago I had one of my hoses replaced i believe the one coming off of the hydro boost to the p/s pump. The liner had come detached inside the hose and was causing a similar noise and vibration I am currently experiencing. Now mainly on cooler mornings I have a very constant humming sound from the firewall area when i accelerate, brake or turn the steering wheel. I have found all the videos pertaining to these noises but nothing about while accelerating. i also have some bubbling in the P/s reservoir not foamy but a constant small bubbling. Im currently working in Midland/Odessa and am looking at 2 month wait to have the truck looked at. Any feedback would be appreciated as I am far from a mechanic and don't want to do any damage to the systems.
 

·
Premium Member
2011 Ram 2500 4x4 6.7 68RFE 4 inch lift
Joined
·
2,660 Posts
Sounds as though air is still in the system. Jack up the front end, tires off the ground and turn the steering wheel lock to lock. Have some fluid on hand incase it’s needed. That should purge the air out.
 

·
Registered
Joined
·
603 Posts
it would be a good idea to check for air leaks, it could be sucking air in making it foam under pressure
 

·
Registered
Joined
·
2 Posts
let me say thanks in advance for any input on this issue.

I have a 2015 Ram 3500 about 8 months ago I had one of my hoses replaced i believe the one coming off of the hydro boost to the p/s pump. The liner had come detached inside the hose and was causing a similar noise and vibration I am currently experiencing. Now mainly on cooler mornings I have a very constant humming sound from the firewall area when i accelerate, brake or turn the steering wheel. I have found all the videos pertaining to these noises but nothing about while accelerating. i also have some bubbling in the P/s reservoir not foamy but a constant small bubbling. Im currently working in Midland/Odessa and am looking at 2 month wait to have the truck looked at. Any feedback would be appreciated as I am far from a mechanic and don't want to do any damage to the systems.
Did you find anything out on this? I’m having the same issues. Been fighting FCA on this for a few years. They ended up replacing the pump and a hose and it fixed it. The noise ended up coming back.
 
1 - 5 of 5 Posts
Top