Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 99 model 24 valve. Wondering how many amps the starter is supposed to pull. My batteries and cables are all good. The starter is pulling 444 amps.

The problem is that it sometimes drags when I go to start it. It is acting almost like I have a dead battery, but they are fine.

Thanks
 
G

·
Starter amperage should be around 450-700 amps.

If the problem is intermittant, you may want to check all connections. If this fails to find a problem, your next bet is to pull the starter. Contacts in the solenoid are also a problem area, and may be the place to start. If you don't find a problem there, check the brushes and see if there are any dead windings.

I have a 99 model 24 valve. Wondering how many amps the starter is supposed to pull. My batteries and cables are all good. The starter is pulling 444 amps.

The problem is that it sometimes drags when I go to start it. It is acting almost like I have a dead battery, but they are fine.

Thanks
 

·
Registered
Joined
·
1,959 Posts
if the bushing is going bad the amps will jump to 900+amps when it is dragging but will read the 444 that you see now when it is not . you will have to read it when it drags to tell
 

·
Mopar1973Man.Com
Joined
·
26,259 Posts
I vote for contacts and/or brushes... It really common and easy to fix too...
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Thanks for all of the advice fellows. Looks like I will be pulling the starter now. It is a fairly new AutoZone starter, so I won't be surprised if it is bad.
 
1 - 5 of 5 Posts
Top