Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
701 Posts
Discussion Starter · #1 · (Edited)
I installed some governor springs a month or so ago and the truck idled fine after the install and ive put maybe 3-4 hundred miles on it since... today it started idling at 1100 rpms but when its in drive it normal. any thoughts? fixes?
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #2 ·
no one? hmmmm, wondering if everyone is on there 7th beer already.......:beer
 

·
SC Chapter President
Joined
·
1,024 Posts
my truck has randomly done that a few times since my GSK was installed about a year ago, have no idea why, maybe they're a little too tight/loose
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #4 · (Edited)
my truck has randomly done that a few times since my GSK was installed about a year ago, have no idea why, maybe they're a little too tight/loose
ya..i have no idea why....wondering if someone else can confirm or deny a governor spring issue?

EDIT**** if it is the governor springs...would they be too loose or tight? back off one round or tighten one round?
 

·
Registered
Joined
·
701 Posts
Discussion Starter · #6 ·
I would try loosening them 1 click. What are they set at now?
DuaL,I appreciate the reply, i honestly couldnt tell ya because i had a dieselshop do it for me because i couldnt pass up the deal they gave me on the labor so i couldnt tell ya. But im thinking i am going in there today. I lost my instructions for doing it myself but correct me if im wrong but TST has those instructions on there website?
 
1 - 7 of 7 Posts
Top