Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
Joined
·
689 Posts
Discussion Starter · #1 ·
Luckily I live in Fl. If I was on a hill in any other state I probably would have had to pull over.
I was pulling 6k lbs up a steep hill and hit 1300 deg. I have the below mods and the Edge was on 1. I am thinking I dont have enough turbo, but really have no idea. What do you guys think could be the problem?

Thanks.
 

·
Registered
Joined
·
403 Posts
you will run a little bit hotter with your mod on your truck . i have the same problem in my truck with it tuned it runs about 200 degrees hotter than stock
 

·
Registered
Joined
·
2,058 Posts
get a bigger turbo!
 

·
Registered
Joined
·
373 Posts
Get a hx40 or a 60 serise turbo. Where are u located in florida?? Im in central and i can get my hands on new turbos for farily cheap. And install it if u are looking for something lik that
 

·
Registered
Joined
·
689 Posts
Discussion Starter · #5 ·
I have a Super B turbo. Thats not big enough?

Duramaxin - I live in central Florida also.
 

·
Registered
Joined
·
1,378 Posts
With your mods, I would be suspicious that the problem is the 4" exhaust. Open it up to 5" and your turbo will spool up better. I would guess you already have enough turbo, what kind of boost are you running?
 

·
Registered
Joined
·
689 Posts
Discussion Starter · #7 ·
^^^^ At the time that it hit 1300 it was at 10 or 11 psi (boost). I was traveling at 50 mph or so and the edge w/att was set on lvl 1.
 

·
Registered
Joined
·
1,378 Posts
??? So you probably weren't really on the throttle at 10 psi. And that would mean that the exhaust would not be a limiting factor. My thoughts would be to look at why the turbo wouldn't be making enough air to keep the egt's low. Air filter, exhaust leaks before the turbo? Seems like something is not right. Perhaps the bigger turbo is lacking boost at lower load levels? (really speculating here) Air leaks between the turbo and the intake?

That is a little toasty to stay at, I was doing a little reading at Turbocharger FAQ maybe you should take a look for yourself. Something I also ran into that could be worth considering is perhaps the waste gate is not closing completely?

Yee Haw! I just realized what you are running! I would look at plumbing. That thing (single right?) should easily make enough air. Check your boot clamps? It's gotta have leaks SOMEwhere. That IS a ballbearing right?
 
1 - 8 of 8 Posts
Top