Dodge Cummins Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I managed to fix my wiring issue that I had earlier, essentially I mean converting from 9004 to 9007. So, so far my high beams work and I don't have an indicator light always on. I can turn my high beams on and the regular halogen bulb turns on. I turn the high beams off and it goes off. However my HID (the whole reason for getting these headlights) will not turn on. I checked all my connections and the HID will flicker on when I plug it into the low beam wire where it should be connected but it will not stay on. What do I do now?:confused013::crying:
 

·
Registered
Joined
·
13,344 Posts
Are the lights on when you plug in the ballast?

Is the truck running when you are trying to turn on the lights?

If you have verified you have 12v and ground to the ballast input, then you either have bad ballasts or you don't have enough power to ignite the bulbs due to the lack of a relay.




Try wiring the ballast right to the battery and see if the bulbs ignite.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
I tried doing plugging it in when the light were on and got a flicker. I also plugged them in and then turned on the lights but got nothing. I have also tried both of those routes while the truck was running hoping to get more voltage but no change. If I wire the ballast right to the battery will that still allow the HID's to come on with the light switch?
 

·
Registered
Joined
·
13,344 Posts
Just jump the ballast right to the batt to see if your ballasts and bulbs work.

The switch won't matter. This is just to troubleshoot
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #5 ·
No that didn't work. I guess that means the ballast is bad.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #7 ·
Roger. Thank you for all your help today. I appreciate it. It's been driving me nuts.
 
1 - 8 of 8 Posts
Top