Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
2012 2500 - Installed Alpha Rex pro gen 2 headlights, HID’S in lows and Morimoto 2 stroke in highs. Everything worked great for about 2 hours....shut truck off turned lights off. Started truck, the HIDS don’t work now. Everything else does, no dash lights or anything. Had a TPMS light pop up for about 2 sec. then went away. What could be wrong here?
 

·
Registered
Joined
·
73 Posts
this happened to me on my side by side and then again on my land cruiser. bad ballasts. I wont use hid anymore...
check fuses first...
 

·
Registered
Joined
·
403 Posts
Same I had too many issues. Went LED, cheaper and put out just as much light.
 

·
Cummins Freak
Joined
·
3,277 Posts

·
Registered
Joined
·
695 Posts
Been running HID's since they first came out 10+ years ago. Many trials and tribulations. Been through lots of ballasts too between many ATV's, UTV, and vehicles. Since i bought my truck in 12' I've been through a few ballasts. I finally got some good ones that have lasted a few years now, but they still mess with my TPMS so I will loose connection with the rear tires while the lights are on.

Did you use canbus decoders or are they built into the ballast already?
 

·
Registered
Joined
·
1,626 Posts
wasn't impressed with led in the stock projectors, maybe other LED's are better, not sure. for anyone putting the led in the reflector housings, most of them are blinding to oncoming traffic.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #8
Been running HID's since they first came out 10+ years ago. Many trials and tribulations. Been through lots of ballasts too between many ATV's, UTV, and vehicles. Since i bought my truck in 12' I've been through a few ballasts. I finally got some good ones that have lasted a few years now, but they still mess with my TPMS so I will loose connection with the rear tires while the lights are on.

Did you use canbus decoders or are they built into the ballast already?
Sorry for the late post.
They were 55watt canbus ballast. But, I bought morimoto leds and put them in Highs and lows, been working pretty good for me, and I didn’t hook up the anti flicker module because idk where to put it and didn’t have the correct wires to run everything. LEDS are hooked up inside headlight, just like normal bulbs would be.
 
1 - 8 of 8 Posts
Top