Dodge Cummins Diesel Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
hey, guys i have a friend who has a 2005 cummins and we have an hid kit for it. we're worried about it doing the flickering thing because the bulbs don't draw as much as the factory lights but don't know what to do to stop it. i read about this fix on the newer 6.7's but haven't found anything for the 05's. is it the same fix? we got a flicker harness with the kit that i think is suppose to fix it. my question is if it doesn't fix it do we just do the same thing they do on the newer dodges even though the bulb type and harness are different? is it basically the same concept? thanks for any help!:confused013:
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
the kit we have is for low beam only we didn't get the high and low kit so i'm assuming we only need 2 resistors, one for each side. i'm not really sure where to put the resistors on the harness anymore help would be great and maybe some pics of where to put them if you have any. thanks again.
 

· Registered
Joined
·
3,377 Posts
the kit we have is for low beam only we didn't get the high and low kit so i'm assuming we only need 2 resistors, one for each side. i'm not really sure where to put the resistors on the harness anymore help would be great and maybe some pics of where to put them if you have any. thanks again.

Will still need to install the high beam load resistors. 2002-2005 Front Control Modules senses the high beams even if it's not being used.

The resistors attaches to the factory plug harness and is tied to ground. I would get a spare 9007 plug with pigtail from suvlights.com and connect the resistor to the pigtail instead of butchering the factory wiring harness.

MikeyB
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top