Dodge Cummins Diesel Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
14,840 Posts
You cant test AC voltage using the batteries because they act as a filter skewing the results. You have to test directly off the alternator. Touch the tester red line to the hot post on the back of the alternator and then the black wire to the alternator body. Thats the most accurate.

Then I advise turning on all your electronic accessories and have a friend sit in the cab ramping the throttle up to 2000 RPM. Test the AC voltage again and it will be higher...

Also, yes it sounds like your CPS is bad or faulty (or the connection) and that can cause problems like you described. :thumbup:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #22
UPDATE: The last few weeks the truck has been running terribly! Anything over half throttle and the truck would stutter like a lack of fuel. The only way I could drive it was around town going no more than 1/4 throttle, so I almost never drove it. Finally bit the bullet and bought a VP pump from Thoroughbred and installed it last night. Bled the lines and took it for a ride this morning and she is running just like new! Problem solved! Also, replaced the Cam Sensor while the VP was off the truck since its a cake walk with the VP out of the way. Anyway, I figured I'd give an update in case anyone else has the same problem.
 

·
Registered
Joined
·
7,727 Posts
Thanks for the update!
It will most likely help someone down the road.
 
21 - 23 of 23 Posts
Top