Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

Registered
Joined
1,616 Posts
Discussion Starter #1
well guys heres something that's rather amusing but would like to figure out with your help. once in a while the tach stops working and goes straight to zero. While it is not working, it feels like the truck's power is derated, takes forever to accelerate, then when the tach starts working again, all the power is back. as far as codes i've got tranny codes cause of the auto to manual swap so those are irrelevant. the other two codes are for p0500 no vehicle speed sensor signal, and p1693 saying that a dtc was set in the pcm....so what are your opinions:thumbsup:
 

Registered
Joined
1,334 Posts
never heard of that. Im curious as to what it is also.
 

Registered
Joined
1,616 Posts
Discussion Starter #3
never heard of that. Im curious as to what it is also.
yessir me to:headbang: from my understanding on the 01 the tach gets a reading from the cam sensor. also if the cam sensor is faulty it shouldnt start. but it starts each and every time with no problems:shock:
 

Registered
Joined
963 Posts
Yep, its the cam sensor. I think theyre 60 bucks at napa. That will get you fixed.:thumbsup:
 

Registered
Joined
1,763 Posts
exact same thing happened to me. the dealership said it was my crank shaft sensor..I thought the warranty was going to covership...NOT..it cost me 400 dollars to have it fixed.
 

Registered
Joined
1,616 Posts
Discussion Starter #7
Yep, its the cam sensor. I think theyre 60 bucks at napa. That will get you fixed.:thumbsup:

cool guess ill be makin a trip to napa purty soon. i love napa:lol4: except the ppl in the napa store 10 miles from me are about as dumb as a box of rocks. go in there holding in your hand the part you need replaced and they will get you the wrong part guaranteed:hehe::hehe: however, the napa store 30 miles from where i live they're VERY helpful, fast, and friendly:headbang::headbang:
 

Not like the others......
Joined
5,116 Posts
I'm not sure which one your 01 has (cam sensor, I think).
If they jack you around at NAPA, then these guys could tell you which one you have and they have pretty good prices too. :thumbsup:

Cummins Sensors
 

Registered
Joined
1,616 Posts
Discussion Starter #9
I'm not sure which one your 01 has (cam sensor, I think).
If they jack you around at NAPA, then these guys could tell you which one you have and they have pretty good prices too. :thumbsup:

Cummins Sensors
thanks man:thumbsup: it's just amusing to me. i mean how much more of an idiot than me do you have to be to pull stunts off like i was talking about at napa:hehe::hehe:
 

Registered
Joined
1,616 Posts
Discussion Starter #10
well guys i officially feel retarded. finally realized that i had a smarty laying underneath my back seat:doh:

p0341 camshaft position sensor signal

p1690 Fuel Injection Pump CKP Sensor
Does Not Agree With ECM CKP
Sensor

so from these two codes i'm gonna try replacing the cam sensor as that is most logical. This is for the fact if it is faulty that would tie into the next code. oh boy happy hunting for me:headbang: i'm just glad these cam sensors are only around 50 bucks instead of the dang apps:lol4:
 
1 - 10 of 10 Posts
Top