Dodge Cummins Diesel Forum banner

help

779 Views 8 Replies 5 Participants Last post by  Offroadjunkie
so ive been noticing my temp gauge has been going back and forth from 200 to about 180 when i take off and when at wot and but cruiseing its 190 it really weriod?
1 - 9 of 9 Posts

· Registered
Joined
·
185 Posts
Try venting the cooling system where it say to vent when filling..... Mine did the same thing until I did it. I had a air bubble from installing the egr delete.....
 

· Registered
Joined
·
454 Posts
Discussion Starter · #6 ·
Try venting the cooling system where it say to vent when filling..... Mine did the same thing until I did it. I had a air bubble from installing the egr delete.....
when i open it is coolent going to fly out or just air
 

· Registered
Joined
·
185 Posts
Coolant wont fly out, just open the plug until you have coolant coming out and tighten it back up...... Not trying to offend anyone but make sure the truck is cool when you do this.
 

· Registered
Joined
·
454 Posts
Discussion Starter · #8 ·
Coolant wont fly out, just open the plug until you have coolant coming out and tighten it back up...... Not trying to offend anyone but make sure the truck is cool when you do this.
lol no problem i did that on my nova once
 

· Registered
Joined
·
1,983 Posts
ya what you can do is fill the radiator until it gets full and then, if you can, let the truck warm up and get to normal operating temperature with the radiator cap off. When the tstat opens up you will see the coolant flowing. After a couple minutes of idling at normal operating temp (on flat ground) you should have all the air bubbles out.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top