Dodge Cummins Diesel Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Ok I just replaced both batteries and now when I start my-truck the wipers come on I was having an issue with them before the batt change I had no intermittent and they would not park back at the bottom of the windshield......




Sent from my Autoguide iPad app
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #2 ·
Bump


Sent from my Autoguide iPad app
 

·
Registered
Joined
·
508 Posts
Your combination switch on the steering column may be badthat would be my first guess
 

·
Registered
Joined
·
307 Posts
I've read that it is the motor. Some kind of sensor or something to stop it at the bottom goes bad.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #5 ·
That's understandable BUT what is causing them to come on when I start the truck Its crazy!!!!!
 

·
Mr. Vehicle Destroyer
Joined
·
11,905 Posts
the contacts in the multifunction switch get copper material rubbed into the dielectric grease that they are built with, so it shorts out a few paths on the switch and turns them on even though the switch isn't on.

you have to take the switch apart and clean the grease out of it. then relube it.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #7 ·
Great Thanks for the info is there any DIY's on that what directions?
 

·
Mr. Vehicle Destroyer
Joined
·
11,905 Posts
Yep, do a quick search for it, there are pics posted and everything in the thread.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #9 ·
Ok cleaned it and still the same, I'm stumped


Sent from my Autoguide iPad app
 

·
Registered
Joined
·
441 Posts
I had similar issues with my wiper motor. Wiper delay wouldn't function properly or wiper wouldn't turn off. I had to buy a new wiper motor from Steve white motors online to fix the problem. Don't get a reman you will have the same issues. I believe there is a park circuit inside the motor that takes a dump.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #11 ·
Was it the same issue as soon as you went to start the truck they come on?


Sent from my Autoguide iPad app
 

·
Registered
Joined
·
441 Posts
No. They just had a mind of there own as soon as I turned them on.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #13 ·
See its when I turn the truck on they start for about 6 revolutions and then stop in the middle of the windshield


Sent from my Autoguide iPad app
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top