Dodge Cummins Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
went to leave work was a little cold started truck . started fine then acted like it was running out of fuel and died. would just crank, put in 5 gal of fuel pumped it up and it started. fuel guage dont work need to fix. went to fill up only held 11 gal. truck runs fine has been running fine. wtf sorry for the long post got to go back to work the joys of being on call 24 7 thanks.
 

·
Registered
Joined
·
736 Posts
probably a air leak in one of the fuel lines. will lose prime sitting.
 

·
Registered
Joined
·
53 Posts
Check all your lines and up under your fuel filter where the separator goes into the bottom of the filter mine leaked from there and did what yours did
 

·
GA CUMMINS CREW PREZ & Captain of the USS FAILBOAT
Joined
·
5,249 Posts
also check the braided line on the back of the block and the return line, slightest hole in them, loose prime and a little air and she is dead...
 

·
Registered
Joined
·
65 Posts
Discussion Starter #5
ok its been two days truck has been siting in drive could not find any sign of a hole in the line no fuel on lines . truck started fine ran for ten min. then i shut it off . could it be from when i park at work the front of the truck is eight inches higher then the rear thanks
 

·
Premium Member
Joined
·
16,224 Posts
You can suck air without leaking fuel. Some air leak locations don't cause problems unless the tank is low.
Best way to find leaks is to pressurize the fuel tank though the fill hole, 10 psi max, then go hunting.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #7
ok it did it again last nite same thing ran for about 15 sec. then died cranked it over pedal to the floor started ran fine only held 13 gal. fuel is there suposed to be rubber hoses hose clamped on the fuel lines thanks:banghead:
 

·
Registered
Joined
·
1,200 Posts
Have you checked for air leaks like illflem said? Thats where I would start.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #9
yes did not find any yet
 

·
Registered
Joined
·
2,081 Posts
Email me at [email protected] for the current version of my 12 valve fuel supply system write up, how it works and how to fix it.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #11
ok did it agin today 35 miles on full tank dont think its a low fuel problem. pumped pedal cept it running poured out white smoke? did not start doing this until after the dealer did the recall on the throttle cable and linkage. going to put air in tank this weekend if i dont half to work.thanks
 

·
Registered
Joined
·
65 Posts
Discussion Starter #12
update

ok it has been a couple of weeks. put 10 lbs. of air in tank got called to work 3 hrs later still had 10 lbs air in tank could find no leaks. only does it when truck is parked with front end down hill.:banghead:
 

·
Registered
Joined
·
4 Posts
i would try and check the lines going to the tank. this sounds like what happened to my truck. the fuel lines were backwards so it was sucking air through the return line that didnt have a clamp on it. swithced em back around hasnt died since
 

·
Premium Member
Joined
·
16,224 Posts
i would try and check the lines going to the tank. this sounds like what happened to my truck. the fuel lines were back wards so it was sucking air through the return line that didn't have a clamp on it. switched em back around hasn't died since
Wow!
First time I've heard of that one.
The person who reversed them should be banned from mechanics for life.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #16
sorry i goofed only does it when front end is parked uphill. other than this truck has run fine for 2 years.
 
1 - 16 of 16 Posts
Top