Dodge Cummins Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1 (Edited)
I was driving my 97 dually and was going through the gears pulling my boat, and all of a sudden the truck started to shutter and shut down. I coasted to the side of the road, and it died. It wouldn't restart, so I thought that the fuel filter plugged. I changed it, and it still wouldn't fire. I bled the the lines to the injectors and still no go. I did the big no-no and used a shot of ether. She would pop off, clank, smoke, and die again. After letting it set for a few hours, it finally started, but it poors out grey and blue smoke. It won't hardly idle (400 RPM), and when I get the RPMs up, it clanks worse than when it is super cold out. It has just enough to move down the road, but I could only get about 6 psi on boost. The egt's went up, but I'm sure that's from the lack of boost. I don't have a fuel pressure guage on it (yet), but I'm thinking the lift pump went out. Help please.

Chuck

P.S. I have a Prime Loc fuel filter relocator kit on it. Does anyone know which port on the filter block will tell the pressure after the filter?
 

·
Premium Member
Joined
·
2,348 Posts
I hate to tell you this but to me it sounds like your injection pump went. The symtops of that are hard starting anf no power.

how many miles are on your truck.
 

·
Registered
Joined
·
861 Posts
it needs a nice bowl of chicken noodle soup, and prob and injection pump :(
 

·
Registered
Joined
·
141 Posts
Discussion Starter #5
It only has 118,000 on it. Now, I can go out and start it right up, but still has tons of smoke, clanking, slow idle, and no power.
 

·
Premium Member
Joined
·
2,348 Posts
Yeah sounds like IP. Have you been using the ultra low sulfur.
Have you been using any additives in your fuel.

In the winter did you use the degel stuff in your fuel, I am not a fan of that stuff because it takes away from what little lube is in todays fuel.
 

·
Registered
Joined
·
141 Posts
Discussion Starter #7
Jake:
yeah I have been running some extra additives for the winter, plus the fuel around here for winter is #2 with additives, not a #1 and #2 mix. It doesn't hardly run on it when really cold, so I add more.

I have also run some homemade bio at about a 70% mix, but that adds to the lubrication. It really quieted down the pump and motor.
 

·
Premium Member
Joined
·
2,348 Posts
When you put #2 diesel back in the engine did it go back to being a little noisy, if not I think that it is the IP. MY friend is in the process of replacing his pump because he ran homemade biodiesel out of both used mineral oil and cooking oil. If you are not careful with the bio it can do some real damage.
 

·
Registered
Joined
·
141 Posts
Discussion Starter #9 (Edited)
Yeah, it is louder now with more diesel in it.

If my IP is bad, where can I get a good one at?
Where can I get my lift pump at?
I prefer to stay with the sight sponsors if I can.
 

·
Premium Member
Joined
·
2,348 Posts
Do you get more power and less smoke with the regular diesel.

Forget to put this in the pm but do you use non-hydrogenated (sorry for spelling) vegatable oil. If not that could be why your pump went.
 

·
Registered
Joined
·
141 Posts
Discussion Starter #12
There is a little less smoke with the diesel, but the power is as good or better with the veggie oil. The oil I am using is the clear stuff, not the milky (hdrogenated) stuff and filtered and thinned well.
 

·
Registered
Joined
·
5,990 Posts
The P7100 pumps are pretty reliable, so I wouldn't go replacing the injector pump right off. Check your mechanical lift pump (cam driven). Remove a fuel line and crank to see if it is still moving fuel. Also check your shut off solenoid on the pump. Usually when these go bad the truck won't shut off when you turn the key off, but you never know.

Have you dealt with the dowel pin on this engine yet? Sometimes referred to as the killer dowel pin, it can come loose on engines of your vintage and take apart the timing gears and make a heck of a mess. Is the truck leaking oil after it died? Does the timing cover look dented out?

-Chuck
 
1 - 13 of 13 Posts
Top