Dodge Cummins Diesel Forum banner
1 - 2 of 2 Posts

·
FUEL
Joined
·
645 Posts
Discussion Starter · #1 ·
ok so i know i might have missed a connection or something but long story short i did a head gasket on my 07 6.7 and now im getting 12v according to the gauge. i havent had a volt meter to it yet but im sure its definitely not charging as it barely turned over after an hour of driving and playing some music etc.

could someone enlighten me as to how our systems charge? only things coming off the alternator are the ground and a small plug. the plug line runs across the front of the block but i cannot see where it heads in the current light. where does the system receive charge? i see where the thick red cable comes out of the drivers side fuse box and to the battery, but where does power come into that fuse panel?

also, havent had a volt meter to the alternator but it could just be bad? 99,000 miles on the truck and the alternator was outside for a couple of days but never any rain.

im thinking i might have pinched and ****ed up the wires coming off the alternator. can i just run two new ones to wherever our system gets its 14v power?
 

·
FUEL
Joined
·
645 Posts
Discussion Starter · #2 ·
Next morning after connecting the batteries after a trickle charge it charged up fine. Connections were clean and all. Chalk one up for the mystery mobile
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top