Dodge Cummins Diesel Forum banner

hard to get into gear after clutch change?

816 Views 2 Replies 2 Participants Last post by  dauer33
In the process of fighting the stealership and crysler about engine vibration on a new engine that they say my dualmass flywheel was causing, i had put a napa clutch in it during the sumer, so i calld them and they waranted it and i got a dualmass relacement solid flywheel with new presureplate and disk. now it was all but imposible to get into 1st and allmost as bad in rev and 2nd. it was like the slave clylnder wasnt pushing far enough so i took the rod out of it and started stacking shims in it to make the rod longer. did they forget somthing of is ther another problem that im not seeing. the dealer is going to have the motor out again so now would be the time to look at it. sory to ramble im bad about it lol oh ya it a 05 with a g56
1 - 3 of 3 Posts

· On a new learning curve!
Joined
·
1,047 Posts
Something is not right with the clutch or the install. Had this to happen with my 97. Resurfaced the flywheel again and another new clutch and no more problem. Make sure they didn't get the disk in backwards.
 

· Registered
Joined
·
146 Posts
Discussion Starter · #3 ·
Not sure on the install, it already had the presure plate bolted to the flywheel ther would have bn no reason for them to take it apart as the flywheel bolted on just like the dualmass did but they first dealer that was doing the work could have screwd up a row bar in a sand pile lol. going to call napa in the morning and c what they say bad part is the dealr said they would have the new motor monday and would hope to have it done on wensday and i dont realy want to take it out myself again lol
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top