Dodge Cummins Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
360 Posts
Discussion Starter #1 (Edited)
Fuel Filter problem!

this happened this morning, It sounded like it fired for a split second and then nothing. I cranked it a few times and finally it started up. It runs fine after start but I dont know what would cause this. Fuel filter maybe? its about 1-2yrs old.
 

·
Registered
Joined
·
53 Posts
this happened this morning, It sounded like it fired for a split second and then nothing. I cranked it a few times and finally it started up. It runs fine after start but I dont know what would cause this. Fuel filter maybe? its about 1-2yrs old.
If your filter is 1-2 years old that would be a good start for sure.
 

·
Registered
Joined
·
2,081 Posts
Leave the fuel filter alone unless you know it's plugged. If it's plugged it would not run fine after start. If you replace it and have an air leak it may make the problem worse. Does it start better if you give it a little pedal? If so then all you need to do is set up the idle. The idle stop wears a little and idle gets a little low. It that doesn't fix it you may have a loss of prime. Look here for how the fuel supply system works and how to fix it: http://www.cumminsforum.com/forum/94-98-tech-articles/58777-joe-g-s-fuel-system-writeup.html
 

·
Registered
Joined
·
1,379 Posts

·
Registered
Joined
·
2,081 Posts
You can't hear the 12 valve lift pump. It's mechanical and does nothing if the engine is not running. It's driven by the cam shaft.
 

·
Registered
Joined
·
361 Posts
You should change the filter anyways even if its not the problem. Its about to be a problem with it being on there almost 2 yrs.
 

·
Registered
Joined
·
2,081 Posts
Mine has been on there a lot longer than that. I still have over 40 PSI fuel pressure on the road. Idles at 30 PSI.
 

·
Registered
Joined
·
1,379 Posts
I bet you got some air in the lines, and it passed it through. Forgot the cutoff date for the 12valve for a moment there!
 

·
Registered
Joined
·
360 Posts
Discussion Starter #9
the last too starts have been fine. Must of been air in the fuel lines.
 

·
Registered
Joined
·
360 Posts
Discussion Starter #10
ok, well I ran into a problem while changing my fuel filter. I replaced the fuel filter and O-rings and went to start it up and it started to leak. After I took it on and off about 3 times I finally saw a small crack on top of the bowl. This is where the leak is.

now, I cold welded it the best I could but I dont think it will work.

Is there any way I can replace this fuel bowl witha new one?
 
1 - 10 of 10 Posts
Top