Dodge Cummins Diesel Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
739 Posts
Discussion Starter · #1 ·
well i swapped out some 75hp nozzles with 125s yesterday and i went to leave for work and my damn truck wouldnt start.. so i got out, cracked number 1 and 3 and 3 had fuel 1 did also but didnt seem like as much as 3.. it cranked right up after that. i took off to wallymart and got back in it to leave and crank crank crank crank crank fire, it almost didnt fire.. any ideas what the heck is going on? do i still have air?
 

·
Registered
Joined
·
7,762 Posts
Assuming it was running fine before the nozzle change, sounds like you're losing prime.
Maybe a leaky fuel tube/injector body connection leak or fuel tube o-ring.
You might try the starter bump to let the lift pump run more to prime the system before starting to buy some time.
 

·
Registered
Joined
·
739 Posts
Discussion Starter · #3 ·
well it always hard started somewhat after i did the first ones, it usualy cranks twice then fires , now its like 4-5 then it will fire.. is there a leak down test i can do to check?
 

·
Registered
Joined
·
7,762 Posts
Not that I know of, maybe someone else knows.
 

·
Registered
Joined
·
115 Posts
im working on a fuel leak on mine right now cant find it anywhere i think a good way to tell if youve got a leak is park the truck with the nose pointed down hill ( a good incline ) if it starts normal then you prolly have an air leak because your loosing prime this wort allow the fuel to roll back the the tank this is how i found out my orings were leaking
 

·
Registered
Joined
·
739 Posts
Discussion Starter · #6 ·
Ah good idea!! What o rings??
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top