Dodge Cummins Diesel Forum banner

Hard Start When Warm/ Oil rising

566 Views 4 Replies 3 Participants Last post by  98whitelightnin
I have a 2003 Comonrail, today it started making a strange tapping noise under lite throttle. It goes away after your cruise speed is reached. I checked the oil, it is rising. After reading some of the discussions i assume i am dealing with a broken injector. Can anybody point me in the rite direction. It also has a hard time starting when warm.Any advice would be great.
1 - 5 of 5 Posts

· GA CUMMINS CREW PREZ & Captain of the USS FAILBOAT
Joined
·
5,525 Posts
bad injector, and the hard to start part could also be from a worn lift pump or and injector leaking back.... do you have any white exhaust smoke? exhaust smell like raw unburnt fuel? pull the dipstick see if it smells like diesel? if you get the positive signs of a worn or bad injector, dont drive the truck, unloading too much fuel on a cylinder will melt it.... :S:
 

· GA CUMMINS CREW PREZ & Captain of the USS FAILBOAT
Joined
·
5,525 Posts
Thanks for the info i don't have any smoke. I will check in to the injectors thanks.
no problem my friend, let me know what you find out... :thumbsup:
 

· On call 24/7
Joined
·
13,768 Posts
If you need injectors dont get them from the dealer. Thoroughbred diesel has new stock replacements for $335 a piece.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top