Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 20 of 27 Posts

·
Registered
Joined
·
707 Posts
Discussion Starter · #1 ·
Does anyone have the newest version of the H&S kit which comes with 3 fooler boxes. The EGT sensors are no longer used in the exhaust, only two bungs for the O2 sensors. Everything else plugs into the boxes. Brad at PDI says it may still throw a soft code. I'm wondering if anyone who has the kit is seeing check engine lights.

Someone on here posted a couple weeks ago and said no CELs. I'm looking into buyin a used one off a member, but don't want to have to buy an edge to clear codes. He only had it on for 1 hour but no codes. The upcoming BADP kit will prob be out of my budget.
 

·
Registered
Joined
·
756 Posts
if you are looking for just the box and delete pipe to fit in place of the dpf then the badp code free kit is gonna be 775 plus shipping which i think is a good price i don't know what h&s is but I'm going with badp
 

·
Registered
Joined
·
707 Posts
Discussion Starter · #4 ·
Well I guess my plan was to get this slightly used H&S module and buy a 5" SS turbo back for a 5.9. I'd only have to weld in 2 bungs for the O2 sensors. Trying to find out how this new 3-box fooler is working for folks that have them. I'm sure they are out there.

Only thing I don't like about the BADP kit is that it still uses the 3 EGT sensors in the exhaust....well that and the price.
 

·
Registered
Joined
·
756 Posts
oo ok i got ya well good luck to ya n keep us posted if yo find it on how it works
 

·
Registered
Joined
·
80 Posts
badptrucks.com
 

·
Premium Member
Joined
·
634 Posts
I have the H&S 3 fooler box setup and my truck ran fine for the first 500 miles. Right now it won't stop trying to regen. I have the batteries disconnected and I hope that breaks the regen cycle. If not, H&S is going to send me 3 more boxes.
 

·
Smells like Bananas
Joined
·
7,242 Posts
I have the H&S 3 fooler box setup and my truck ran fine for the first 500 miles. Right now it won't stop trying to regen. I have the batteries disconnected and I hope that breaks the regen cycle. If not, H&S is going to send me 3 more boxes.
for the battery trick to work you need both batteries disconnected(if not this could get ugly), Hold the positive and negative leads together for 30 sec or more.
 

·
On a new learning curve!
Joined
·
1,053 Posts
I just got the standard email back from H&S that says you need the edge to keep the CEL off. Either they don't have the code free out yet or are not ready to feed the masses.
 

·
Premium Member
Joined
·
634 Posts
I did disconnect both batteries, but I didn't hold the neg and pos together. Is that important? So far the battery disconnect has had no effect. I expected to get soft cel's, but the edge should clear them. The edge isn't clearing this regen for some reason. Hopefully the new fooler boxes they are sending me will work. I will post after I try them.
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Edge wont clear regens. I am sure you have but have you double and triple checked your connections? Seems to be the biggest cause of issues.
 

·
Premium Member
Joined
·
325 Posts
Cottondoc,

This happened to me and this is my best guess at what is happening and why all the regens.

You cannot clear the cat full codes because the computer has set a state and the code(s). You cannot clear the code(s) unless that state is changed by the computer.

The states that send it into a tizzy are 100% full, 90% full, 80% full and 70% full. The computer will only update that state after attempting a regen which it thinks was successful. So it will attempt a regen and if all three EGT probes send back the proper signal it will consider the regen a success. Maybe other sensors are involved but I know if the EGTs do not send back values the computer likes it will consider the regen a failure.

So say the 100% full state got set. The computer will initiate an active regen and then check on the sensors. If it likes what it "sees" then it will update the state to 90% and then you will get another regen and the process starts again. Once you get to below 70% then the overhead display will disappear and you should be able to clear the codes.

HTH
 

·
Premium Member
Joined
·
634 Posts
Diesel_Fitter, I think you are right about the computer thinking a regen is necessary, but if I have a DPF delete with fooler boxes that never change their signal, how do I get the computer to think a regen was successful? If the new fooler boxes don't work, I don't have a clue what to do. I have left the batteries disconnected for hours, and that didn't seem to help. Do I have to go to the dealership to get the computer reset? That is going to be bad, since they may not even do it when they see my DPFs are gone. Also, if reset, the computer might just eventually go back into regen when it thinks its time. Is there anybody else out there with the H&S DPF delete with a similar problem? If so, how did you fix it? Thanks for any info. I need help as I am having to bum rides off of friends right now.
 

·
Premium Member
Joined
·
634 Posts
The new boxes didn't fix it. The truck still goes into regen in about 2 minutes after cranking it. I don't think there is anything wrong with the boxes. For what ever reason the truck decided it needs to regen and nothing short of completing a successful regen is going to fix it. Anybody else out there with a similar problem with a DPF delete? Any help at all would be greatly appreciated. Thanks.
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Is it possible for you to put the DPF back on, run it around til the Overhead clears it then try installing it all again?
 

·
Premium Member
Joined
·
634 Posts
I am planning on getting access to a Bullydog powerpup right now to reset the code. PDI says that should fix it.
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Cotton, you should fill out your signature in the User CP so that we can tell exactly what you are dealing with.
 
1 - 20 of 27 Posts
Top