Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just had an after market stereo system installed on my 2003 Dodge Ram turbo diesel Cummins. Ever since then the battery guage, fuel gauge, and the speedometer doesn't work. Also the parking brake light stays on even though it's not engage. The abs and engine light is also on. Someone suggested that it might be the ecm. I'm trying to find a wiring diagram to find out if the instrument cluster wires are connected to the ecm. Need some help here.
 

·
Trying to learn
Joined
·
6,232 Posts
Was it broken when you picked it up from install?
Hopefully, they unhooked the batteries before starting work on it, could have shorted something.

Try unhooking all 4 battery cables, then let it sit for 1/2 hour. Be sure the post and inside clamp are clean/brite before the reinstall.
 
  • Like
Reactions: rghavana

·
Trying to learn
Joined
·
6,232 Posts
Again, Was it broken when you picked it up from install?
For the wiring diagram get FSM here.
 
  • Like
Reactions: rghavana

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yes, it was broken after we picked it up from having a stereo system and subs installed. Worked just fine before that. I've been working on the truck after work and I'm finding some very poor connections. I'm hoping that's it.
 

·
Trying to learn
Joined
·
6,232 Posts
You should be making them foot the repair either way. I would have been right back in there before ever making it home.
 
  • Like
Reactions: rghavana
1 - 7 of 7 Posts
Top