Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
hello there so i have the 1992 cummins in my sig nd i tried turning up the full power screw ive done everything else so i already had it turned into the collar nd it seemed tyo help but today it snowed to much haha so was in the show nd pulled off the collar and i screwed it bvack in but i cant seem to get it any farther it feels like im runnin outa threads or something in the pump has moved and its blockin the screws path as theres still a 1?4 of threads past the nut it isnt near the run away point at all my idle picked up just a little tho but do i have to pull the pump apart or..??? sorry for the long post guys but im trying to make it sound as it is :banghead:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
ya the treads are clean and the bolt turns fine on them but it just bottoms out and wont go any farther my govenor also i dunno if its working rite as in free reving it it will probly go past 3200 rpms... but when driving u can feel it defuel at 2700 or around there never looked closly but i know the pump isn't been opened up so has gone bad in there or what do ya guys think?? im planning on getting the 3200 govener spring pretty soon so i wil be opening it up but can ''things'' fall apart in there?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
ya the treads are clean and the bolt turns fine on them but it just bottoms out and wont go any farther my govenor also i dunno if its working rite as in free reving it it will probly go past 3200 rpms... but when driving u can feel it defuel at 2700 or around there never looked closly but i know the pump isn't been opened up so has stuff gone bad in there or what do ya guys think?? im planning on getting the 3200 govener spring pretty soon so i wil be opening it up but can ''things'' fall apart in there?
 

·
Registered
Joined
·
716 Posts
Mine is the same man, tonight I was messin with it and I still have a 1/4 of the threads but it won't go any further. My idle jumped 200 rpms but when it revs it comes down to 400 and lopes back to 1100... Does yours do that if you spike the throttle?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
no mine returns to idle just fine everything else seems fine like im maybe 2 turns past the stock setting on er the only other thing thats kinda weird is when ya just rev it up in neutral it will like ''snap'' or 'rap' kinda like its real loud in the exhaust idk that probly has nothing to do with it but if anyone noes bout that to..? haha
 

·
Registered
Joined
·
716 Posts
Mine revs then drops below idle then jumps back up, sounds like it's just starting
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
hmm i dont got any idea bout that i havent worked on VE pumps much just bought this truck nd playing round with it now i bumped the pump right to the head and that helped quite a bit and messed with the star whell etc runs better now anyways
 
1 - 8 of 8 Posts
Top