Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Cummins of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
1999 Dodge Ram 3500 5.9 24valve
Joined
·
5 Posts
Discussion Starter · #1 ·
Alright guys, I’ve been reading threads on these forums for awhile now, and I’ve got a question that I can’t seem to have anybody help me with. So Cummins owners/mechanics, I have a 99 24valve 5speed, 4wd. Edge comp box, I have replaced the lift pump with an AirDog Raptor, new Fuel Head that eliminates canister for screw on filter, XDP injection pump, New ECM, New APPS, MAP. The truck at idle when I start it is at 15psi. When I’m driving it’ll be about 10-12psi, but when I get on the pedal to pass someone or simply to get on the pedal, it will drop down to about 4-5psi. Ever since I’ve replaced the VP44, it wants to lose fuel pressure after it sits for about 30minutes or longer, and will have issues wanting to start back up. No visible leaks of fuel anywhere that I can see, so any help would be grateful! Thanks.
 

·
Registered
Joined
·
20,918 Posts
Sounds like something wrong with your lift pump or after market filter system or fuel intake not providing enough fuel.
 

·
Registered
Joined
·
20,918 Posts
And what is that going to change. Nothing.
 

·
Registered
1999 Dodge Ram 3500 5.9 24valve
Joined
·
5 Posts
Discussion Starter · #5 ·
Sounds like something wrong with your lift pump or after market filter system or fuel intake not providing enough fuel.
I have done a couple things since I have posted this. I have replaced the injectors with DDP Stage2(75hp) injectors, a big line kit from the fuel head to the VP, and new stainless limes from VP to injectors. I’m not losing fuel psi anymore after it sits, will start right up. As for the fuel dropping when I stomp it, it’ll only drop down to about 5psi and now it seems I’m almost having a turbo lag when I stomp it as well. It’ll be spitting smoke and a Boost gauge will bounce between 20-28psu and the power seems delayed to me? IDK..
 

·
Registered
Joined
·
20,918 Posts
Sorry with such mods you are out of my expertise now. Except it should not dropping to 5lb even with those injectors. Look at it for boost leaks all the way from the turbo to the head.
 

·
Registered
1999 Dodge Ram 3500 5.9 24valve
Joined
·
5 Posts
Discussion Starter · #7 ·
Sorry with such mods you are out of my expertise now. Except it should not dropping to 5lb even with those injectors. Look at it for boost leaks all the way from the turbo to the head.
Yeah there is no boost leaks, the only thing I can think of, is that the turbo isn’t spooling up fast enough for all the fuel it is getting
 

·
Registered
Joined
·
272 Posts
5 psi is plenty. Mine would do the same thing regardless of what fuel pump I had on it. Do you have a boost elbow on it ? It might be over boosting and opening the gate too early.
 
1 - 9 of 9 Posts
Top