Dodge Cummins Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
529 Posts
Discussion Starter #1
I guess I will start with the fuel plate question. I pulled my afc housing and was going to slide the plate forward, well I got to the fuel plate and noticed something. It isnt the same as a stock fuel plate. I pulled the plate and took a picture to show you guys (below). When I bought the truck the guy said nothing was done to it :confused013:..My question is there is a number 8 stamped on it so I assume its a #8 fuel plate?? Just to make sure before I start going on another question. Am I Right?

 

·
Registered
Joined
·
166 Posts
Was the break-away bolt still intact?
 

·
Registered
Joined
·
529 Posts
Discussion Starter #3
I didnt take a chizzle to anything, there were three 8mm bolts and one flat head bolt. All came out easy.
 

·
Registered
Joined
·
529 Posts
Discussion Starter #5
Ok so my question now is, with this plate slid all the way forward, why is it still a dog, I try brake-boosting and it quits at 10 psi, my next step is jumping into the afc, I have it off the truck now and was going to do some adjusting, I just figured with a plate in it already it shouldnt be such a dog, I was kind of shocked when I saw this, any help?
 

·
Registered
Joined
·
529 Posts
Discussion Starter #6
I got the afc apart, I was going to do the washer mod but didnt have any washers, Ill do it tomorrow night, the one thing I did was put one of my old gsk springs in, I read on here and that it was a good idea, I adjusted everything to were it would be max fuel right off the stop. AFC housing mounted all toward the motor, star wheel as loos as it gets, an fuel screw in the back all the way in flush with the lock nut. The funny thing is, theres little smoke, just a haze. Im not going for smoke I just want some power.
 

·
Registered
Joined
·
166 Posts
We have a Ford F-800 1997 we bought.... Has a 5.9 cummins with a p7100. Drove it from Sacramento to Oregon. No power. Good god I was disappointed.. was worried something major.. looked at it with fresh eyes after not being able to go over 35 mph on grades... It's flaw...the little tube was broke from wastegate to afc not letting it fuel.. replaced a $.98 part.... Yes ..98c part ... Thought to my self really?.. this can't be all?... Jumped in and this 13,000 lb dump truck took off like a bat out of hell and didn't slow down on the hills,70 mph.. just my .02c...
 

·
Registered
Joined
·
529 Posts
Discussion Starter #8
I was told to replace the OFV on Comp D. I will try that and check all hoses. Another thing I would like to point out is as Iam going up a grade and start losing mph, I have to literally stand on the pedal and it wont down shift nor pick up speed, unless I turn the OD off then it obviously shifts down and slowly picks up speed. I really hope its a fuel issue because as I have everything tuned and reading all about plates and afc tuning, theres no power and no smoke.
 

·
Registered
Joined
·
536 Posts
make sure you do a boost leak test.. you can find posts on how to make a leak tester.. i had a bad intercooler that led to other problems with no power being my main concern..
also, i had to turn my preboost screw "in" towards the rad, to allow more preboost fuel to get my turbo to light.. once its lit, she runs great.. then i turned the starwheel toward the engine to get more fuel there and now she smokes some but clears up and runs pretty darn good... now i just have to watch the egt's.. she gets real hot now..

just some stuff to look at and try
 

·
Registered
Joined
·
166 Posts
Going up grades was the worst...35 mph.. hunting between gears.. tube reconected and it hauls... Surprise what a little boost missing does..to the afc....
 

·
Registered
Joined
·
529 Posts
Discussion Starter #11 (Edited)
Here is a link I found on a leak down test, I was looking at the pictures posted, I get everything up until were he connected to that pipe under the intake, if I do what he did, will that pressurize the whole system, also what is the max psi I should push through the system. Thanks for the information guys I really do appreciate it!


http://www..com/dodge-diesel-tech-articles/35017-pressure-testing-intake-system.html

Also, XEC - I adjust my pre-boost screw all the way in to were it is flush with the locknut as well as even a little adjusted back out, and I have had the starwheel FF as well. Still nothing.
 
1 - 11 of 11 Posts
Top