Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
393 Posts
Discussion Starter #1
Ok i just installed my AD 150 on the 6.7 and im getting a fuel leak from the factory return line right where it clips on the sending unit, how do i fix this? Also what do i do with the lines from the factory LP?
 

·
Registered
Joined
·
2,340 Posts
Just hook that line back up to the stock fuel canister. The fuel system still circulates fuel back through that line.

If you tied into the cp-3, just cap off that line. Or if you are never going to use them again, you could cap it at the outlet of the canister.

Randy
 

·
Registered
Joined
·
393 Posts
Discussion Starter #3
Thats what i did but it's still leaking, only when i drive it around not when its idling.

I took the factory supply line going from the CP3 to the factory LP off so what do you use to cap that off at the factory LP?
 

·
Registered
Joined
·
2,340 Posts
Is it leaking close to the tank where you disconnected the stock line that went from the tank to the filter? Or is it coming from the engine bay?

You did disconnect the power to the factory pump--right?

You should be able to just bend the rubber hose back on itself and use a clamp to seal the end of the hose. Or jam a small bolt in the hose and clamp it.

Randy
 

·
Registered
Joined
·
393 Posts
Discussion Starter #6
I did disconnect the fuel pump.

The fuel leak is coming from on top the sending unit where the factory return line is connected to the sending unit.
 
1 - 6 of 6 Posts
Top