Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter #1
well i just installed my arson kit and boy it runs good! but today i went for a drive and got on it getting on the highway, when i pulled off i smelled fuel so i pulled over and looked under the hood and fuel was pouring out from somewhere on the cp3, just wondering if there is a trouble spot where i can start looking, thanks in advance
 

·
Tech Specialist
Joined
·
459 Posts
check what appear to be small freeze plugs (3 of them) make sure they're all there. have seen them pop out. then check the lower high pressure portion of the pump. the seal leaks sometimes.
 

·
Registered
Joined
·
257 Posts
Discussion Starter #3
it does kinda look like it could be a freeze plug towards the block can i just reinstall it?
 

·
Tech Specialist
Joined
·
459 Posts
i've heard of people getting new plugs and reinstalling them, but i personally have not (the dealership won't let me)
 

·
Registered
Joined
·
257 Posts
Discussion Starter #5
ok would it be easier to get a plug, if thats what it is, from cummins or dodge? you also said to check th bottom of the pump? where at?
and if it blew a plug would it still run fine?
 

·
Tech Specialist
Joined
·
459 Posts
it still runs ok, don't know how. the plug i heard was matched up at a local parts store. under the rail feed, looking down, the assembly with cooling fins has a o-ring behind it. hope this helps
 

·
TECH SPECIALIST
Joined
·
408 Posts
the other spot to check is in between the two case halfs of the pump that is a common spot to leak
 

·
Registered
Joined
·
257 Posts
Discussion Starter #8
it still runs ok, don't know how. the plug i heard was matched up at a local parts store. under the rail feed, looking down, the assembly with cooling fins has a o-ring behind it. hope this helps
ya i just replaced the low pressure pump. i have everything un hooked and ready to pull out, just need to bring the gear puller home from work. if i feel around on the side towards the engine it feels like there is a chunk missing from the plug on that side.:confused:
 
1 - 8 of 8 Posts
Top