Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter #1
Ok so I got a Fabtech 4.5" installed and while I was driving home I heard and felt a bad (Pop) in the front end. It even felt like my tire threw a really huge rock in my fender well because I felt the Pop (Vibration) through my seat and not just the floorboard. Now I hear and feel something loose on the driver front end like a shock or shock mount broke. But after inspections I see nothing. Any suggestions?
 

·
Registered
Joined
·
624 Posts
Well, first of all, I'd probably take it back to the shop that installed it before touching it myself. If you mess with it yourself you open yourself up to liability.
 

·
Registered
Joined
·
336 Posts
Discussion Starter #3
Of course I will take it back in the morning. But I am putting a set of eyes on everything I can before putting it on highway speeds. Im wondering if I can get some pointers on people that may have had this before. Or pointers on were else to look.
 

·
Registered
Joined
·
2,344 Posts
Of course I will take it back in the morning. But I am putting a set of eyes on everything I can before putting it on highway speeds. Im wondering if I can get some pointers on people that may have had this before. Or pointers on were else to look.
Could be several things....front drive shaft, bad shock, loose bolts, I'm not familiar with fabtech lifts though. Does the noise come and go, or continuously make the noise?
 

·
Registered
Joined
·
128 Posts
I have the same lift and if you are talking about a knocking feeling in the floor boards then there is nothing that they can do. I pulled the front driveline off and it drove like a brand new truck with no vibration in the floor at all. I talk to George at 8 lug and he said they have had alot of issues with the front drive line on these trucks. Call him he might be able to help. Also I talked to Jesse at High angle drive lines today and he said he could biuld me a custom 1 off CV and would solve all my issues. As of now I have a 2010 Mega cab lifted 2x4

Erik

 

·
Registered
Joined
·
1,568 Posts
I've had extremely good experiences with Jess at High Angle Driveline. He built a CV rear shaft for my lifted 01 as well as a couple sets of axles for my sandrails. No connection other than buying experience (and he's only 100 miles away).
As far as the popping sound, is it possible they tightened down the control arm mounts up in the air? You're SUPPOSED to snug the bolts, but not tighten them until they have the weight of the truck on them. Maybe the urethane bushings popped under some heavy rotational force?
 
1 - 6 of 6 Posts
Top