Dodge Cummins Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1 (Edited)
Hello everybody, I just barely had an 8" Zone lift kit installed in my 2010 Ram 2500 short bed crew cab 4x4. The truck rand fine from the shop for about 100 miles then when I got home I noticed that whenever I start slowing down from maybe 20 mph I get a grinding noise from the front end from what seems like both sides of the front axle best I can hear from the cab. Truck runs fine at high speed though! Lift installer told me my lower ball joints would need replacement soon but would this cause this sound? Front driveshaft does have indexing rind installed. Any help would be greatly appreciated just wanting to make sure truck is drivable
 

·
Premium Member
Joined
·
338 Posts
Noise could still be from your front driveshaft. Some trucks are fine with an indexing ring and some aren't. You may need to get it lengthened and balanced.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3 (Edited)
In the instructions it had the measurements of the driveshaft angle to see if you had to use the index ring and the measurement on mine said it didn't need one but I noticed the shop ended up putting it on anyways. I think that may be causing it but I plan this week to do a reverse level in the rear which might put the front driveshaft at the correct angle with the index ring correct? Either way am I messing anything up by driving this way temporarily?
 
1 - 3 of 3 Posts
Top