Dodge Cummins Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
just had my auto trans rebuilt..and upgraded tourqe converter and valve body installed as well. i was on duty working (EMS) when i picked it up so i had to take it back to my work and park it. so when i was done with work and driving home, the f*ckin transmission starts slipping and acting up REAL bad!! i could not believe what was happening to me. so i floored it a couple times because i was so pissed, and limped it on home. parked it and checked the trans fluid and what do you know...NO fluid on the g*ddamn dipstick! maybe a tiny little bit of fluid smudged on the side, but no reading what so ever. cant believe it. ofcourse i picked it up on friday so no1s gonna be in the shop alll weekend. I just want to leave it sit...empty, but after a week and a half in their shop i dont have the luxury of doing that. goin to grab fluid to throw in it now so i can have a vehicle this weekend. but all i keep thinking about is what kind of shape are all those new parts i paid for in? F*ck this...
 

·
Registered
Joined
·
171 Posts
just had my auto trans rebuilt..and upgraded tourqe converter and valve body installed as well. i was on duty working (EMS) when i picked it up so i had to take it back to my work and park it. so when i was done with work and driving home, the f*ckin transmission starts slipping and acting up REAL bad!! i could not believe what was happening to me. so i floored it a couple times because i was so pissed, and limped it on home. parked it and checked the trans fluid and what do you know...NO fluid on the g*ddamn dipstick! maybe a tiny little bit of fluid smudged on the side, but no reading what so ever. cant believe it. ofcourse i picked it up on friday so no1s gonna be in the shop alll weekend. I just want to leave it sit...empty, but after a week and a half in their shop i dont have the luxury of doing that. goin to grab fluid to throw in it now so i can have a vehicle this weekend. but all i keep thinking about is what kind of shape are all those new parts i paid for in? F*ck this...
I know it would suck to have no vehicle but I wouldn't touch it, then Monday mourning I'd call and tell them to send a tow truck.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
I know it would suck to have no vehicle but I wouldn't touch it, then Monday mourning I'd call and tell them to send a tow truck.
too late..already put fluid in it. took 6 qts and its driving good now. right now, according to the dipstick, theres a little too much in it now.
 

·
Registered
Joined
·
463 Posts
wow 6 quarts low...I would be steaming mad. Truth is you probably didnt do it any harm, it just didnt have enough fluid in it to get the pressures where they needed to be to make it act properly. I would have stopped and checked the fluid as soon as it started acting up though

how many miles did you drive it?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #5
not sure how many miles but yea i took a little drive with it..and like i said before, when i was at a red light and it turned green and the truck wouldnt move, i frickin punched it bcuz i was so pissed! so that wasnt no good either. but 6 qts went in but the dipsticks showing too much in it now....aaggghh!
 

·
Registered
Joined
·
463 Posts
just undo one of the cooling lines and let some out...dont try and drop the pan.

You may have done some damage...I would have them open it up
 

·
Registered
Joined
·
44 Posts
Discussion Starter #7
i have some drippin out the bottom now. think i coulda popped a line loose or something if i put a little too much fluid in? how are the lines fastened? thanx bigD
 

·
Registered
Joined
·
463 Posts
the lines are threaded in so if they are tight they shouldn't leak...can you get a pic of where the leak is coming from?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #9
i can get under there and snap one with my iphone. i dont know how to put em on here though, i can send it right to ya if youre cool with that.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #11
my man, check for it in a lil bit. anybody else is more than welcome to give some input.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #12
Big D- it appears that fluid is dripping from the main seal area...? didnt check the fluid level again yet since i initially put the fluid in
 

·
Registered
Joined
·
48 Posts
Had the same thing happen to me about a month ago i blew a transmission line and didnt notice it until i stopped at a gas station and noticed a solid stream of fluid leaking under the bottom of my truck to make a very long story short apparently dodge doesnt make that line anymore and my mechanic tried to rig it up with just a rubber hose and some clamps and well that didnt work now because 3 hours after i got my truck back it blew that line again and i am looking at another complete rebuild and having to find that hose at a junkyard or somewhere and im still not even sure which hose it is he just told me it was one of the quick connect hoses?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #14
ok i have an update. spoke to the owner of the shop today and; apparently there was enough fluid in the truck when i checked the level - according to them. they said that all the fluid that i put in was just about all extra, despite the truck driving much much better after putting the fluid in. on the automatic dodge transmission, any extra fluid will discharge out of the pump/vent in the front immitating a bad seal. and what i interperated as a "slip" was actually a failure to shift. also, what i interperated as the converter coming out of lock-up upon acceleration from stop was actually the transmission failing to downshift out of the previous gear. so when i was in overdrive and came to a stop, the trans remained in OD. so, when i attempted to accelerate it would rev up to approx 1000 and i would go nowhere until it realized it was in the wrong gear and would shift into first. which to me just felt like it wasnt catching then slamming into gear. so what is actually the problem is there is a problem with the communication to the trans about the actual speed of the truck, causing incorrect shifting. so now they need to search for the electrical / scensor problem that is causing the miscommunication. good to know though, because miscommunications like this that cause consistent shifting misques will slowly but surely KILL your transmission. im glad that the problem was discovered and being solved. one thing though, that truck was driving soo sh*tty that night and the next day i put that fluid in and it was driving fine? that confuses me but hey, what the hell do i know. ill get back to everyone and let you know what happens. BigDeezul thanks for your help, never got around to taking that pic.
 

·
Registered
Joined
·
209 Posts
sounds like an improper kickdown linkage adjustment..... my 95 gasser shifted fine when i took it in. Trans rebuilt, shop couldnt get it to shift right, so new valve body went in(mine had shift kit). After that they called me and said it was done come get it. I pulled out of the shop drove down the street and no downshift at the red light...... I got home popped the hood and the kickdown linkage was set all the way loose.... i had to pull it like half way back. After the warranty was off, my vb went back in and its shifted fine since.
 
1 - 15 of 15 Posts
Top