Dodge Cummins Diesel Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
I dropped the pan on my tranny yesterday to change the Pressure sensor and solenoid and found a few things that shouldn't be there. Anyone know what theses are?? There is also that little steel flap hanging there. Its on the passenger side from of the valve body area, but not on the valve body. Replacing the sensor and solenoid didnt fix the shift problem either. It wont do the 1-2 shift right. RPMs go all the way up and I have to let off it for it to shift and then ease it up to 2K RPMs or it pops back outta gear.




 

·
Registered
Joined
·
129 Posts
Thats the 2nd gear band strut.
It works off that servo strut in pics 4 & 5.
You need to remove the valve body to reinstall.
Did somebody try and anjust the bands?
This is the reason you have no 2nd gear...
 

·
Banned
Joined
·
5,596 Posts
I don't know what that junk is but an HTS valvebody cured all my woes.
 

·
Premium Member
Joined
·
15,373 Posts
Thats the 2nd gear band strut.
It works off that servo strut in pics 4 & 5.
You need to remove the valve body to reinstall.
Did somebody try and anjust the bands?
This is the reason you have no 2nd gear...
Exactly!!!
 

·
Registered
Joined
·
225 Posts
Discussion Starter #7
Ive had the truck for about 15K miles and this is the first time Ive had the pan down. It started doing this about 3K miles ago. Is there any place that has a step by step of how to drop the valve body and re-install these parts? I can take an engine down to bare block and back again but Ive never done a transmission.
 

·
Registered
Joined
·
691 Posts
Someone linked a how-to article a few days ago. I'm trying to find it for you now.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #10
That helped a little. Im still searching for some good pictures of how those parts are supposed to be in there.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #12
Sweet. That even had pictures of where those parts went. Any idea what would have made those parts come loose?? I guess I need to loosen the front band untill I can get those parts back in and then re torque the band to the correct pressure?
 

·
Registered
Joined
·
691 Posts
I can't answer your questions because I don't know. However, I'm exceptionally good with the search button. Lol!! I'm sure someone will chime in and help you out.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #14
LOL. Thats cool man. You helped me out big time either way. Thanks a million!
 

·
Registered
Joined
·
232 Posts
quick question i think i mite be in the same boat i tap on my pan and it sounds like there is somthing in it did yours do the same thing or did you just drain it and take it off to find those in there? also mine hesitaites in 2nd some times grinds a little do you think it mite be the same thing.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #17
I didnt tap on the pan at all. I just dropped it, not expecting to find anything like this, and got a big surprise. I have no grinding. I can take off in first and it just wont shift unless I let off. If Im going up a hill it will bang out of gear until I let off again and it catches again, but if I put pressure on it it pops out again.
 

·
Registered
Joined
·
106 Posts
All of this your describing is because you were missing 2nd gear.
Yes you have to run that adjuster back out far enough to get all the parts correctly put into place. then tighten that adjuster to the specified amount (72inlbs maybe??) then back it out the prescribe number of truns (2maybe) and tighten the lock nut. I think those are close although I might be thinking about the way I do my race trans.

good luck.
 

·
Registered
Joined
·
232 Posts
OK cool do you think there might me something in there for me to hit it and it sounds like something is in there or is it just the pan making that noise sorry these are dumb questions i just don't know a lot about this stuff trying to learn thanks
 

·
Registered
Joined
·
225 Posts
Discussion Starter #20
There shouldnt be anything loose in the pan. Just a magnet stuck to the bottom of it.
 
1 - 20 of 34 Posts
Top