Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 20 of 33 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
Ok I have a 2010 4 wheel drive Dodge Ram that looks like a beast. It has 3.73 rears and is totally stock. I tow a 12K lb 5th wheel. It's first trip out did not impress me. My past 2 trucks, one a 2500 2wd and my last one a 07 3500 2wd dually towing the same trailer where great. They would tow that trailer with no problems. Unless it was a long or major grade at 65 mph it would just purr up the hill and never downshift. This new truck the least little grade it will down shift and if it is a steeper grade I have the foot to the floor. It is to the point that if I had to tow up a steep hill not sure the truck could do it. It pulls out from a start fine with the load and runs right up thru the gears. But on a hill that I would have been passing cars on with the old 07, I am in the right lane now. I don't have no check engine lights and truck seems to run fine and shift fine. And towing on a 45 degree day the tranny temps were between 140 to 165 and engine temps stayed normal. So could the 4wd unit make that kind of difference or could there be something else I need to check. Thanks........oh and no I am not deleting, I need the warranty lol lol
 

·
Premium Member
Joined
·
1,958 Posts
What gears did the other trucks have what transmissions what mods
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #3 ·
My last truck was an 07 6.7 dually no mods and tranny was stock 6 speed not sure of the numbers... I do think the trannies is different in the 2010's but still 6 speed. The rears in both are 3.73's. Just the 2010 doesn't seem to have the pulling power the 07 had and the only difference is the 2010 is 4wd and the 07 was 2wd.
 

·
Registered
Joined
·
1,572 Posts
How many miles on the 2010? How old are the air/fuel filters?
 

·
Registered
Joined
·
317 Posts
your 2010 has some big restrictions in the exhaust DPF.

assuming everything is working as it should for stock get a programmer and see how you like the truck then.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #6 ·
The 2010 only has 43K miles on it very low. The dealer says they did a full service on the truck in Dec. I checked the air filter and it looks new so I am assuming they changed the fuel filter. But I am still going to change it when I get home to make sure that is not the problem. Adding a programmer is just hiding the main problem. Besides like I said I travel all over with this 5th wheel and need my extended warranty since breaking down in BFE is not an option. Kinda like being able to call a tow truck and pay my $100 to fix it.... I was told that these 4th gens are just lame compared to the 3rd gens I had. Others have said they think it's a difference in the trannies....
 

·
Registered
Joined
·
317 Posts
having the ability to set your torque converter lockup and adjust the throttle percentage of the throttle pedal would make it seem like a completely different truck these are two things a smarty jr would do for you. the most basic tuner.
 

·
Registered
Joined
·
230 Posts
My last truck was an 07 6.7 dually no mods and tranny was stock 6 speed not sure of the numbers... I do think the trannies is different in the 2010's but still 6 speed. The rears in both are 3.73's. Just the 2010 doesn't seem to have the pulling power the 07 had and the only difference is the 2010 is 4wd and the 07 was 2wd.
Was the 07 a manual 6 spd? If so, that would make a huge difference, going to a 6 spd auto.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #9 ·
Nope 07 was a 6 speed auto too....the only difference in the 2 trucks is 07 was 2wd and the 2010 is 4wd.....I really think there is a problem just not sure what it is since truck runs fine, gonna run it by the dealer tomorrow and see what they say..
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #10 ·
Oh and here is the other part, I only got 8-9 mpg where I got 11-12 with the 07. Now I expected a drop going to a 4wd but not that much of a drop......And the exhaust brake is also kinda wimpy compared to the 07.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #12 ·
Hmmm after talking to the dealer he tells me I ain't the first to complain about this. He tells me it is the tranny and it is set up different then the 3 Gens. But he tells me they can check for a reflash and see if there is something they can download to help it. Deleting is really starting to sound better even with the extended warranty lol lol ....so now we'll see what is up when I get it into the dealer for service....
 

·
Registered
Joined
·
7,185 Posts
WOW you sure you don't have a E Brake on or something ? had a 08 2500 auto and a 2011 3500 both with 410's if your going to be pulling that type of weight get some pulling gear's Both of My truck's pulled Like a wild Mule empty stock was a easy 16 or better and pulling was also a easy 10-12 and I was never Easy on either truck . or the only other thing is there is something wrong with trans the 373's should not make that much of a difference pulling . or maybe they do .
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #15 ·
Ok basically it comes down to tire sizes. My tires are 285/70/17 which are 2 sizes over stock. It is just enough that when I am in 6th and doing 65 I am only doing 15-16k rpms....need to be closer to 18k for the little extra power. The 2 sizes also changes my rear ratio from 3.73 to 3.60 which also don't help. So basically I will be locking 6th gear out on the rolling hills until these wear out and I can go back to the standard size. And no a tuner will not help, it will only change the tire size to fix the speedo. On the new trucks it does nothing to the tranny, Dodge don't want us messing with it lol lol
 

·
Registered
Joined
·
161 Posts
Something is up with your truck. My 13 4x4 6 speed auto pulled my 12-13k 5th wheel toy hauler with ease.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #17 ·
I know we are just finding out. After I got my truck back it threw a CEL. Well dealer said it was the wiring or connector to a O2 sensor and they have a repair kit for that but would take all day to fix. Now they call yesterday and say that got that done and still a CEL on. They talked with Dodge and now it is determined one of my CAT's are clogged, Hmmm $3000 part but under warranty. It will be in on Thur. so we'll see after that. But that sounds a whole lot more logical then the tire size. The trucks previous owner lived in Austin Tx which has very terrible stop and go traffic. So the truck may have been driven slow and idled a lot. That won't happen with me lol lol
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #18 ·
Ok in case anybody is watch this, it was the NAC cat, it was clogged. No more gear hunting and I have my top end power back. Makes me a happy camper now......
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #20 ·
I figured too and even tried to ask could it be a clogged CAT or DPF...they were stuck on the tires. Both my 5.9 and my Gen 3 pulled the same trailer like a raped ape. My mind kept saying well that must be it they are the experts but my brain said that's a bunch of crap??????? If the CEL hadn't lit I would still be going round and round with them....
 
1 - 20 of 33 Posts
Top