Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,284 Posts
Discussion Starter #1
So of course I get VR that is not labled IASF. Of the three tabs in a cluster when I look at the tabs, is the A on the far right or is it left? The pictures I found in the tech thread shows the A tab as being the far right (or top when mounted with tabs facing right) but the descriptions all list the order as IASF.
 

·
Registered
Joined
·
1,284 Posts
Discussion Starter #2
SO I found the diagram and it is from left to right I-A-S-F. I go outside FINALLY and decide to check voltage flow. At the batteries it has 14.25 volts. At the alternator it has 14.25 volts. Chances are SLIM to NONE it is the regulator, right?

That only leave the batteries as the problem...:spank:
 

·
Registered
Joined
·
1,284 Posts
Discussion Starter #3
So I cleaned up the battery connections and cables. I installed the external VR.
As soon as I turn the key to "on" the alt gauge on dash shows 12 volts. I start the cummins and the gauge stays at 12 v and SLOWLY climbs to 14 v.

I check the battery power when running and it tops out around 14.24, then it drops to 13.25 and climbs back to 14.25. It holds for 45 seconds or so and cycles back to 13.25.

Gauge looks the same as it did withou external vr. Is the gauge just gone bad??

It does this with or without the headlights on.
 

·
Registered
Joined
·
50 Posts
Could be you're grid heaters cycling on/off--you can pull the two wires for the grid heater near the intake to see if that's whats causing it
 
  • Like
Reactions: zthatzmanz28

·
Registered
Joined
·
1,284 Posts
Discussion Starter #5
Could be you're grid heaters cycling on/off--you can pull the two wires for the grid heater near the intake to see if that's whats causing it
Sometimes I really have to :buttkick:

So now, the cummins is HOT, the alt gauge still moves like molassess, BUT when I check the batteries for voltage they are holding 14.35 v...steady.

Headlights drop it a little to 14.15 v and blower motor drops it to 13.98 v with headlights.

I guess I have to drive it with headlights on and see if it charges enough to restart. The ALT GAUGE is making me paranoid..:shock:
 

·
Registered
Joined
·
1,284 Posts
Discussion Starter #6
So could a weak or dying battery cause the ALT gauge to move slowly? I checked the battery terminals this morning and both are at 14.5 volts when cummins is running...
 
1 - 6 of 6 Posts
Top