Dodge Cummins Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
I have a 2001, 5 speed with 154000 miles. As far as I know it's stock other than the adrenaline I've installed and 4" exhaust.

This truck always seemed to smell different than other diesels. The exhaust smells like there is unburnt fuel, and burns your eyes if your near by in the shop. Even after it has warmed up the smell is the same. Sometimes there will be a haze or blueish smoke coming from the exhaust.

I don't think this it normal. I've owned an 06 CTD and it was completely different. The exhaust didn't stink nearly as bad. It smelled like it was burning the fuel and running efficiently. I'm around large diesel engines every day, caterpillar and cummins, and again it's not the same.

The exhaust from my truck is so bad, if you walk by the tail pipe you can smell it on your clothes for the rest of the day. Not the case for any other diesel engine I'm around.

Is this normal for these trucks, or should I be looking into it?

Thanks,
Anton
 

·
cumminsforum.com
Joined
·
26,302 Posts
Any error codes???

Maybe a leaking injector???

Timing issue with the VP44???
 

·
Registered
Joined
·
93 Posts
Discussion Starter #4 (Edited)
Last time I checked I had a P0222 and P1693. I pulled these codes with my smarty, and cleared them. The light has since came back on, but haven't checked yet what they are.

I do not have a smarty program installed, only the Adrenaline. I bought it to get the 3cyl high idle feature only.

I'm running a holley black type pump, and run around 15 PSI.

I had reset my APPS to the specified voltage, and cleared the codes immediately afterward. I believe this is the idle validation circuit problem.

MoparMan, other than throwing a code, what problems might an apps with a bad idle validation circuit switch cause? The truck seems to operate fine, it idles at around 850.

When I purchased this truck, I drove it for about 5000 miles without codes. This includes about 1500 miles with the Adrenaline without codes. The truck has seen maybe 10000 miles since I bought it.
 

·
cumminsforum.com
Joined
·
26,302 Posts
MoparMan, other than throwing a code, what problems might an apps with a bad idle validation circuit switch cause? The truck seems to operate fine, it idles at around 850.
Well the APPS is shot for sure... The idle validation controls your exhaust brake, high idle and a few other things too...

I don't suggest adjusting the APPS. Read my warning on my page...
APPS Sensor
(Towards the bottom of the page!)

Here is a alternate APPS sensor that is cheaper...
Alternate APPS
 

·
Registered
Joined
·
433 Posts
Mine smells different too! Almost nauseating defiantly not like other diesels I've smelled.
No codes though and running like a top with good economy. :confused013:
 

·
Registered
Joined
·
347 Posts
Asheng... mine gives off the smoke when in high idle, and after its been running for a while. I'm watching my mileage closely, maybe stuck injector, Idk. Not throwing a CEL, maybe soft code though.

FYI, replaced my APPS because of surging at 45-50 MPH. Dealer wanted 530 bucks, found on Ebay dealer for 369+ s&h.... works great now
 

·
Rescue Tower
Joined
·
10,827 Posts
There are cheaper APPS's to be had. Mopar1973Man's second link on post #5 is $160... I think some of the parts stores have them too for around the same price.
 

·
Registered
Joined
·
347 Posts
Wish I would have join here long ago, oh well, now I know. I checked at parts stores here nobody carried it, I looked for quite some time to find a better price. I laughed at the dealer parts guys when he told me the price. Anyway, thanks for the heads up, keep in mind when the next 180K come around.
 
1 - 9 of 9 Posts
Top