Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
The fuel system is about 3 years old and had been working well. Started getting erratic pressure readings that I suspect are erroneous. Normal pressure is about 18psi, then I see very low numbers to include zero but only for a second, may go for hours ok then get a number of alarms in a short time period. Have even seen 35 psi once and I know that is crap. I am thinking electrical noise on the sensor lines, called Edge and wasted my time with some kid that knows less that I do about their system.

Has anybody had this type of problem?? Any ideas??
 

·
Registered
Joined
·
352 Posts
Could be the fuel pressure sending unit.
 

·
Registered
Joined
·
1,685 Posts
I would check the fuel pressure with a test gauge then check the wiring and connections for the fuel pressure sensor. If you still don't solve the problem you could possibly have a bad sensor.
 

·
Rescue Tower
Joined
·
10,813 Posts
Verify with a second gauge, but if you didn't put a needle valve between the injection pump and the sending unit it's guaranteed the sending unit died from being hammered with injection pulses. Lost of posts on that.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
Verify with a second gauge, but if you didn't put a needle valve between the injection pump and the sending unit it's guaranteed the sending unit died from being hammered with injection pulses. Lost of posts on that.
No needle valve installed, I am thinking that a failing sending unit is the best bet.

Thanks for the responses.
 
1 - 5 of 5 Posts
Top