Dodge Cummins Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
63 Posts
Do you have any codes, check eng lights? Did u check your fluids, check belts (possible alternator belt blew and batteries died? Check voltage of batteries...
 

·
Premium Member
Joined
·
45 Posts
My guess is fuse box is bad......mine has progressively gotten worse over the last month or so, sometimes it won't start and sometimes it won't shut off.....dodge said they are backordered and they "put me on the list" but expect to be a long wait, mine has never shut off while driving but it sure is a pain in the a** not knowing wether it will start or shut off when I want it to
 

·
Registered
Joined
·
838 Posts
My guess is fuse box is bad......mine has progressively gotten worse over the last month or so, sometimes it won't start and sometimes it won't shut off.....dodge said they are backordered and they "put me on the list" but expect to be a long wait, mine has never shut off while driving but it sure is a pain in the a** not knowing wether it will start or shut off when I want it to
I had to have my TIPM replaced twice on my '06 ... so I'm onmy 3rd one now already. Are you telling me that Dodge still doesn't have this figured out in 2012?
 

·
Registered
Joined
·
1,802 Posts
I checked the batterys and pulled the post and cleaned them and still nothing
Do you mean you did a load test on the batteries? You may have juice but not enough to activate the ecm.It is voltage critical,I forget what it is but it's nearly 12 volts.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top