Dodge Cummins Diesel Forum banner
1 - 11 of 11 Posts

·
Registered
2005 dodge ram 3500 srwlb
Joined
·
16 Posts
Discussion Starter · #1 ·
i had bbi .05 injectors installed a week ago. then i had the tuner installed with the tunes a few days later. when i picked up the truck, the engine ran rough and sounds like it has a miss to it.
i have already ruled out the tuner and tunes for it because it ran like this before the tuner was installed and after the tunes was installed. i had the bbi .05 new injectors installed. i have a mm3 tuner with tunes from rob (diesel camper)
so i'm trying to think of what to look at to see if i can fix it myself before i take it back to the shop.
oh, i also had a new fuel rail with both sensors installed at that time also.
i also had them install new fuel tubes i got from cummins. but they called me and said the engine would not build pressure with the new tubes for some reason, so they installed the old tubes. and it fired right off. ( i do have new fuel tubes from bbi being shipped right now.)

so i topped off the oil level on the engine before i left work tonight. after i did that, it seens like the engine has smoothed out a little bit.
 

·
Registered
Joined
·
10 Posts
2006 Ram 2500. I’m sort of having the same issue. After new injectors, lift pump, and tuner my truck runs ruff. Im not getting any codes. I have yet to pin point it yet. If I figure it out I will let you know. I’m following to see if anyone can solve your problem. Good luck.
 

·
Registered
Joined
·
69 Posts
Bad install. Put new tubes in and follow the proper installation. If the other tubes didn't build pressure, they weren't properly installed/torqued.
 

·
Registered
2005 dodge ram 3500 srwlb
Joined
·
16 Posts
Discussion Starter · #4 ·
wierd thing is the same shop installed the last injectors on my truck with no issues.
this time, issues..the new tubes should show up next monday.
i also found it wierd that cummins tubes didnt build pressure. and the tubes are martched to the serial number for my engine.
 

·
Registered
Joined
·
69 Posts
wierd thing is the same shop installed the last injectors on my truck with no issues.
this time, issues..the new tubes should show up next monday.
i also found it wierd that cummins tubes didnt build pressure. and the tubes are martched to the serial number for my engine.
New tubes can be finicky. Typically I've had to go a bit beyond the torque value to get them to seat. If you have one or two that don't seat correctly, you'll never get enough pressure to start the truck.
 

·
Registered
Joined
·
8,365 Posts
Haha, smoother, better we can call it what ever you want, adding oil to an engine and it runs different is either a coincidence or you have an lube issue, should find out.
So what is oil pressure with real gauge, Factory gauge is fake.
 

·
Registered
2005 dodge ram 3500 srwlb
Joined
·
16 Posts
Discussion Starter · #9 ·
Haha, smoother, better we can call it what ever you want, adding oil to an engine and it runs different is either a coincidence or you have an lube issue, should find out.
So what is oil pressure with real gauge, Factory gauge is fake.
Enough with the attitude please.
I have already dealt with the oil leak i knew about.
 

·
Registered
Joined
·
8,365 Posts
No attitude intended, sorry if you took it that way , you just made a comment that could of been pointing to a pretty serious issue and I was pointing out that factory gauge is an idiot light with a pointer.
 

·
Registered
2005 dodge ram 3500 srwlb
Joined
·
16 Posts
Discussion Starter · #11 ·
No attitude intended, sorry if you took it that way , you just made a comment that could of been pointing to a pretty serious issue and I was pointing out that factory gauge is an idiot light with a pointer.
No, i agree with you, the factory oil pressure gauge is an absolute joke.
If my mm3 had that gauge, id be using it
 
1 - 11 of 11 Posts
Top