Dodge Cummins Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
:banghead:On my 06, the engine light comes on. When i have it checked, they say intake heater, so they clear the light. The voltage drops to about 9V when the heaters cycle on, and back to 14V when they cycle off, THEN the check engine light comes on. But it continues to cycle 9V then 12V, 9V then 12V.....
I get the light turned off, but next time the heaters cycle on/off, the light come on again. What gives? Why does the engine light keep coming on, and how do i stop it? :S:
 

·
Registered
Joined
·
233 Posts
have you checked your batteries they could be on their way out or possibly corroded connectors
 

·
Premium Member
Joined
·
7,069 Posts
Next time cycle the key on off on off on and leave it on. Write down the code shown in the odometer window. Post the actual code number's. It might help
How cold is it where you are?
 

·
Registered
Joined
·
233 Posts
Marko did you figure out your problem :confused013:
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 · (Edited)
Hey oilurner99, I did not yet, i cleaned the terminals acouple weeks ago when i removed the cables trying to clear the light, i haven`t check batts yet will do 2morrow.
And when i cycle the switch on/off/on/off/on, only the check engine light blinks 10 times then 1 very quick (flicker) NO CODES WHERE THE ODOMETER IS.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top