Dodge Cummins Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I recently had the fuel line heater programmed to actually work and now I noticed another thing happening.. At cold start up, there is a clicking sound under the hood on the passenger side and when it clicks, my lights go dim and blower fan slows.. It does this back and fourth until the truck gets to about 140 degrees.. Took it to the dealership and told them exactly what it is doing and when.. So they take it directly from the customer service area back to the shop without letting it cool down to see what's going on at cold start and tell me there is no codes... NO ! Anyway, anyone else having this? Sounds like something is pulsing power and dragging other things down.. Also, does anyone have a light ticking sound under truck, especially after warmed up?
 

·
Registered
Joined
·
1,842 Posts
Sounds like the grid heater cycling on and off during a cold weather start. Sounds like normal operation to me. Mine does the same thing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Right on, that was what I was leaning toward.. The mechanic was guessing that was what it was..
 

·
Registered
Joined
·
1,001 Posts
Sounds like the grid heater cycling on and off during a cold weather start. Sounds like normal operation to me. Mine does the same thing.
Yup, that sounds about right.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top