Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Looking for some help with my 1999 dodge ram 2500. The other day I went out to start my truck in the morning and it was dead so I jumped it and it ran fine, voltage was fine, next day it started but voltage was low, around 11 on dash guage. Next day when I went to start it all my dash lights came on like normal besides the wait to start light, it kicked in after the other lights turned off but it dropped the voltage all the way. I am replacing battery cables and connectors and an going to get my batteries tested. Just curious if anyone else has had this problem cuz the only thing that worries me is the delayed wait to start. I am also resting apps and ecm right now to see if that helps. Thank you all.
 

·
Registered
Joined
·
295 Posts
Well, bad batteries will cause all kinds of problems. Report back after testing and if you put new ones always use group 27. Not too sure what resting the ecm means. Is that re-setting? How? The wait to start dropped your voltage down because it's running your grid heaters. A big draw on those crappy batteries.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Looking for some help with my 1999 dodge ram 2500. The other day I went out to start my truck in the morning and it was dead so I jumped it and it ran fine, voltage was fine, next day it started but voltage was low, around 11 on dash guage. Next day when I went to start it all my dash lights came on like normal besides the wait to start light, it kicked in after the other lights turned off but it dropped the voltage all the way. I am replacing battery cables and connectors and an going to get my batteries tested. Just curious if anyone else has had this problem cuz the only thing that worries me is the delayed wait to start. I am also resting apps and ecm right now to see if that helps. Thank you all.
Well, bad batteries will cause all kinds of problems. Report back after testing and if you put new ones always use group 27. Not too sure what resting the ecm means. Is that re-setting? How? The wait to start dropped your voltage down because it's running your grid heaters. A big draw on those crappy batteries.
Good to know thank you very much, and yes my bad I meant re-setting not resting lol
 

·
Registered
Joined
·
19,663 Posts
You need TWO new group 27 batteries. One is all done and the other following. Do both. If cables or clamps are bad replace them, otherwise clean well. That will be it. Nothing fancy just good quality batteries,
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
You need TWO new group 27 batteries. One is all done and the other following. Do both. If cables or clamps are bad replace them, otherwise clean well. That will be it. Nothing fancy just good quality batteries,
I just put in two new batteries and cleaned connections with a wire brush and it fired right up with no delayed wts light. Thank you for the help!
 

·
Registered
Joined
·
19,663 Posts
You are welcome.
 
1 - 6 of 6 Posts
Top