Dodge Cummins Diesel Forum banner

EGT's on 6.7

2169 Views 23 Replies 18 Participants Last post by  Ram Tough55
I just installed my new gauges and have been watching my egts and they seem to be running too high. The gauge is showing up to 1400 at times on a stock truck with little to no load on it. I wanted to find out what other people are getting on stock trucks with the 6.7
1 - 20 of 24 Posts

· Registered
Joined
·
824 Posts
1400 means you are going into regen. it's normal, i still do'nt see how it can be safe, but every 6.7 does it with the dpf still on.
 

· Premium Member
Joined
·
2,622 Posts
Yep that is a normal regen temp. When my truck was stock I could hit 1500 going up a hill during regen.
 

· Registered
Joined
·
467 Posts
mine will hit like 1480 or so with the edge and mp8 when i am hard in it.. is that ok? i have dpf and egr delete.. s&b intake ..... is that ok or even around right?
 

· Registered
Joined
·
351 Posts
I don't have a 6.7, but out of curiosity, are those temps pre or post turbo?
 

· Registered
Joined
·
1,671 Posts
I don't have a 6.7, but out of curiosity, are those temps pre or post turbo?[/QUOTE

Pre turbo. I am getting the same temps often!! My truck will see 900 deg. just driving down the road in front of my house. These 6.7's run HOT!!!!!

One other thing I noticed was that my truck went into regen and then about 2 minutes after it went out my egt's were through th roof

Chris
 

· Registered
Joined
·
351 Posts
I wonder what the long term wear is going to be on the turbos running those kinds of temperatures.
 

· Registered
Joined
·
718 Posts
My EGT's were like that when my truck was stock. 1300+ when it went into Regen and then 1000-1100 durning driving, and 1200+ while towing. With the mods I have now, I'm around 680 at 70mph, and while towing a 28ft trailer at 11,400lbs I'm around 850-900. I can't even hit 1300 anymore :thumbsup

Gotta get rid of that DPF and that delvish EGR to get the good low EGT temps for the life of your engine. My 02.
 

· Registered
Joined
·
723 Posts
Just the electronically operated actuator for the VGT is water cooled, but supposedly the turbine is made of inconel and is super heat resistant.
 

· Registered
Joined
·
212 Posts
every wheel i have ever heard of was made out of inconel hell i had a set of turbo headers on a 383 sbf made out of inconel tubing expensive as hell but no cracks!
 

· Registered
Joined
·
66 Posts
Discussion Starter · #13 ·
thanks for the help. iwas starting to think that there was something wrong with the probe or gauge because eveyone i talked to said that was way too high.
 

· 700hp Club
Joined
·
2,197 Posts
My EGT's were like that when my truck was stock. 1300+ when it went into Regen and then 1000-1100 durning driving, and 1200+ while towing. With the mods I have now, I'm around 680 at 70mph, and while towing a 28ft trailer at 11,400lbs I'm around 850-900. I can't even hit 1300 anymore :thumbsup

Gotta get rid of that DPF and that delvish EGR to get the good low EGT temps for the life of your engine. My 02.
X2:thumbsup
 

· Registered
Joined
·
2,565 Posts
From examining a spare turbo it appears that the water path goes across the housing rather than straight through the electronics so even if the primary purpose of the water is to cool the electronics the housing has water flowing through it from one side to the other so there has to be some cooling benefit to the entire assembly.

 

· Premium Member
Joined
·
8,859 Posts
with my water meth I wont see over 1450 but with out I have seen over 1800
 

· Registered
Joined
·
186 Posts
Boy I'm glad somebody started this thread, cause I was wondering the same thing. When I installed my Edgew/att. and saw the egt's I got scared. When just running around it was 900-1000 and when in regen it was anywhere from 1100 to 1400. I thought maybe I installed the probe wrong or something. By the way what is the regular Engine temp? Or a good running engine temp. The reason I ask is because occasionally it will hit 210 degrees. And the preset edge alarm goes off.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top