Dodge Cummins Diesel Forum banner

EGT Gauge/Probe

1052 Views 5 Replies 5 Participants Last post by  illflem
My EGT gauge has quit working and i thank it could be the probe but I don't know if that's possible... :confused013: The gauges are not that old. I Got some pics so y'all give me you input PLEASE!!!! Is there a way to test the probe or gauge?? The pic of my gauge is with the truck on and warm. It never moves from that point unless you shut the truck off. Thanks......Randall

Attachments

1 - 6 of 6 Posts

· Registered
Joined
·
9,910 Posts
Hmmm, typically the probes will tend to get whacky after a few years and require replacement.

Not sure on what the specs should be for testing the probe, but if you throw a multimeter on it and test resistance you should find the resistance vary if you heat up the tip with a lighter. If their is no resistance between the 2 probe wires (open circuit) or the resistance doesnt vary if you heat the tip, the probe is your issue.
 

· Registered
Joined
·
667 Posts
just do what he said just dont take the lighter off and grab it. but its just a thermister so it should have resistance with heat on it. you could always do a continuity test and make sure there is no break in the line.
 

· Registered
Joined
·
80 Posts
Discussion Starter · #4 · (Edited)
(Don't grab it)!!! :hehe: That sounds simple enough.. Thanks guys for the help.. :thumbsup: Oh one more thang....... What if you get the probe to HOT?? BullyDog says don't go over 1,250* which doesn't make much scene because the gauge goes to 2,000*.... I know i have hit 2,000* many times.. :doh:
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top