Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Cummins of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
New to this forum though active on others. Thanks for having me. My question: I have an Edge CS Juice w/Attitude and the sereen of the readout has gone black. I tried unplugging the readout and doing a "hard reset" which has been helpful in the past but no help this time. I'm pretty sure it's just the readout as the truck (2002 2WD automatic w/Banks billet converter, 275 HP injectors, FAST lift pump/air separator, ) feels about the same but I can't read my instruments. Does anyone fix these? I talked to someone at Edge a while back and they sort of blew me off saying that my system was long out of production and not supported. Any imput would be appreciated.

Here's a pic of the truck
931141
 

·
Registered
Joined
·
500 Posts
New to this forum though active on others. Thanks for having me. My question: I have an Edge CS Juice w/Attitude and the sereen of the readout has gone black. I tried unplugging the readout and doing a "hard reset" which has been helpful in the past but no help this time. I'm pretty sure it's just the readout as the truck (2002 2WD automatic w/Banks billet converter, 275 HP injectors, FAST lift pump/air separator, ) feels about the same but I can't read my instruments. Does anyone fix these? I talked to someone at Edge a while back and they sort of blew me off saying that my system was long out of production and not supported. Any imput would be appreciated.
Did you try plugging it into a computer and seeing if you can update it on the edge website?

Also I would contact Edge again, I have the CTS and it wouldn't activate even after the truck warmed up. They had me send in both parts and fixed it free, even though I had no idea how old the underhood programmer was.

Sent from my SM-G975U using Tapatalk
 
  • Like
Reactions: tryNto

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Did you try plugging it into a computer and seeing if you can update it on the edge website?

Also I would contact Edge again, I have the CTS and it wouldn't activate even after the truck warmed up. They had me send in both parts and fixed it free, even though I had no idea how old the underhood programmer was.

Sent from my SM-G975U using Tapatalk
Probably worth contacting them again. I might have worded my request wrong or maybe the rep was having a bad day. I'll start there - and thanks. As far as an online update - I'm old and didn't know such things are possible. I'll look into that, too.
 

·
SuperModerator
Joined
·
10,412 Posts
931162


Edge customer service has always been great with me.
Old is not a deterrent, Go here look at the Fusion section, then follow directions.
You will need the USB cable to hook from the computer to the Edge module, which you unplug from the truck and bring inside.

If you think you can you will.
If you think you can't you won't.

I'm part of the elder sector myself.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Thanks! I get a lot of compliments on the ol' boy. His job is pulling the race truck (see my profile pic) to the track on the trailer.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Just so you guys know - my system really is too old for them to support. They claim that they can’t get parts anymore which seems odd but I can’t make them work on it. I suspect the led’s have burned out but that’s a guess. I’ll look for a local person who does generic electronics repair and see if they can think their way thru it.
 
1 - 7 of 7 Posts
Top