Cummins Diesel Forum banner

EDGE JWA and MP-8

966 Views 14 Replies 8 Participants Last post by  GH4AU
Anyone run this setup and have issues with tranny or headgaskets or anything else? I havn't seen much feedback on this setup lately since XRT and MAXX have come out.
1 - 15 of 15 Posts
i am right now no problems edge on 3 and mp-8 maxed out i get excellent mileage
i'm looking at doing the same mods, what kind of mileage do you consider excellent?
It may not be be all that great but in a trip at 400 miles I made 22 at 85 + or - a mile a gallon I consider it great because I averaged at 65 15 mpg so that's great for me
Its a damn good running set up I ran edge hott and mp8 max all the time basically, good running sweet set up!! Mileage on mine was never better then 16 17
Its a good setup. Shouldn't cause any issues. I know numerous people that have ran or are running the setup and have no issues at all.
Thanks for the info guys, but I'm wondering if my lift will effect the tranny's longevity with this setup? I'm sure it has to do with my right foot to.
running this set up for 20K and love it
I ran it for a little over a year with no problems. Edge was on 5 or hot, mp8 at 100% most of the time. I was running my 37"s the entire time as well. I had no tranny problems while running that stack. My best mileage was 17-18 on the highway. My city mileage was 13-14.
GH4AU are you still running the edge? I dont see it in your sig, if not why?
No I sold it to get the Black Maxx. I was tired of not being 100% code free and the Black Maxx is far superior IMO to the Edge.
No I sold it to get the Black Maxx. I was tired of not being 100% code free and the Black Maxx is far superior IMO to the Edge.

Why was the Edge not 100% code free? Maybe the EGR delete?


Could you not block off the EGR but keep the valve plugged in? So the computer thinks its till there but its not actually effecting anything?


Still a newb , please explain
I run the edge jwa and the mp-8, not totally in love with the set up, but the truck runs great, no tranny or any other problems. looking to upgrade to the smarty stacked with mp-8.
I run the edge jwa and the mp-8, not totally in love with the set up, but the truck runs great, no tranny or any other problems. looking to upgrade to the smarty stacked with mp-8.
Why don't you like it that much. Just wondering.
Why was the Edge not 100% code free? Maybe the EGR delete?


Could you not block off the EGR but keep the valve plugged in? So the computer thinks its till there but its not actually effecting anything?


Still a newb , please explain
The EGR cooler delete was still throwing a code that couldn't be cleared by the Edge. I even tried plugging the motor back in as some folks were saying that with the motor plugged in that the Edge would clear the code but mine never would. I also got tired of having to "wait to start" while the Edge was clearing codes. The Black Maxx Allows you to turn all that crap off and be 100% code free and just fire right up without having to wait to clear codes.
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top