Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Cummins of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
750 Posts
Discussion Starter · #1 ·
Well i finally got around to installing my edge tonite and my tranny didnt like it one bit. Felt real bad slipping, on level five with low end responsive on extreme. Wont be going back on that setting until i get my TC and Vb.
 

·
Washington Chapter Vice President
Joined
·
5,055 Posts
Congrats on the install.
 

·
700hp Club
Joined
·
2,196 Posts
are you sure it is the tranny and not just running out of fuel?? i thought my edge was defueling on the track because the truck was kind of learching, mabye the TC was slipping. next run i looked at the backdown % and there was none = no slippage detected. turns out i was out of fuel, installed a fass system and now she pulls like a freight train all the way down the 1/4. what other mods do you have done? unless you have an upgraded air system and exhaust upgrades you should not be running the edge on higher levels unless you like unplugging your DPF every week.
 

·
Registered
Joined
·
750 Posts
Discussion Starter · #4 · (Edited)
I have edge by itself and i am pretty sure that it is the tranny, my backdown says zero, but now my tranny shifts different now after i put the edge on. For example it really dumps the gears into overdrive now, if you get what i mean. It feels like it is struggling to go into overdrives. But i might just be crazy so we will see, run it till its broke and find out whats the deal.

Oh and my truck is pretty much in regenerating everyday anyway, i only drive it in the city back and forth to the gym lately, so i am waiting to get my exhaust.
 
1 - 4 of 4 Posts
Top